Jump to content
Corsair Community

Two Problems with my New H80i


Harold

Recommended Posts

Hi Everyone,

I am a new member, this is my first post.

 

I decided to ditch my great big air cooler and replace it with the H80i.

It arrived yesterday and the installation went well, no trouble so far.

 

On turning on the PC, the two H80i fans appeared to run flat out for a few seconds then throttled back to a slow RPM. The system is very quiet, the Corsair ICON is white, my core temps in the mid to high 30's where they usually are with normal use. I assumed that the pump is working OK.

 

However, the "USB Device Not Recognised" message popped up and the device was not installed. In device Manager I have the "unknown device" yellow triangle.

I searched this forum and did what was suggested. I uninstalled the device and rebooted, switched to auto device driver update, unplugged and reconnected the USB cable, nothing worked. Windows keeps telling me that I have the best driver for the device.

 

I know that it should work, but I don't know why it wont.

 

The second problem is with Corsair Link, I have never used it before so I am new to it as well. I decided to install it and maybe update the Firmware. I ran CorsairLinkInstall_2.2.0.exe and was told that I needed NET Framework4 before installing CorsairLink. I have NET framework4 installed as I have another Progam tha needs it.

I probably could not do a firmware update anyway as the device is not detected.

 

I have now unplugged the USB cable to get rid of the nag messages.

The core temps are still in the mid 30's, I have no idea where they would go under stress testing.

 

So that is it, nothing works except the pump, I think:[pouts:

What do I do next, I live in Australia and I bought the unit locally.

 

Thanks for any help.

 

Harold.

Link to comment
Share on other sites

The H80i uses the default Microsoft HID drivers.

 

Try this if Windows keeps installing the driver.

 

Turn off the auto download drivers from Windows and see if that helps.

 

Advanced System Settings > Hardware > Device Installation Settings > Check "no....."

 

Have you tried reinstalling Net. Framework 4? Also Net. Framework 4.5 install it and see if that solves the problems.

Link to comment
Share on other sites

Toasted - I understand what you said about the drivers, I tried Auto ON and OFF before, nothing worked.

I reinstalled Net. Framework 4 again, it worked. Looking at my Windows Update History it now shows up twice. I don't know why it did not work with the original, my other App did.

Looking at CorsairLink DEVICES, all I see is Disk Drives - CPU - and NVIDIA GeForce, no Hydro USB or H80i detected.

 

My question is, is there anything else I can do to get the USB Device recognised in device manager, or do you think it may be a faulty unit.

Link to comment
Share on other sites

Thanks Toasted, I'm too worried about Dashboard at this stage.

Firstly, I have to get the unit recognised in Device Manager.

 

I did "Right click unknown device > properties > details > hardware ids."

Nothing happened, all I got was "USB/UNKNOWN"

 

I have tried everything suggested on this forum and plus some.

Unless there in anything else to do, is the unit dead, is it time to send it back.

I don't want to go down that path, but I am running out of options.

 

I have never encounted a problem with any other USB device, my mouse uses the HID drivers.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...