Jump to content
Corsair Community

M90 not working on windows 8


JeffSG

Recommended Posts

I had this mouse working well on my old computer with windows 7 but I can't get it to work on my new computer with windows 8. I can move the mouse (right and left click ect.) but the settings I adjust don't do anything. The drivers install but don't really work. The assigned macros don't do anything and the dpi changes have no effect. I'm used to cheap mouses so the default dpi is much too high for me. I tried reinstalling everything a few times and the steps on this thread: http://forum.corsair.com/v3/showthread.php?t=104856

 

Does anyone have it working on windows 8 because I was really happy with the way it used to run on windows 7.

Link to comment
Share on other sites

Yes, The M90 is working fine on my system. The latest software and firmware does support Windows 8.

 

Have you tried running the configuration software as admin?

Try a USB 2.0 port

Latest BIOS and chipset drivers?

Does Device Manager mention any errors?

Do you have any other gaming mouse software installed?

Link to comment
Share on other sites

I just tried reinstalling and running as admin in a usb 2.0 port and there was no difference. I'm using a brand new ASRock Z77 extreme 4 mb. I'm going to check and see if I need to update any drivers. The device manager doesn't mention any errors and this is the only gaming mouse I have.

 

Here is the information window. I did have the latest update installed at one point but it didn't fix it and and when I reinstalled everything I couldn't get the update to run again. It took several tries to get the update to run the first time.

 

 

Software: 1.00.00.29

USB Mouse:

VID: 0x1B1C

PID: 0x1B31

Manufacturer: Corsair

Product: Corsair Vengeance M90 Mouse

Firmware: NA

Windows: Windows 8 Pro 64 bit

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...