Jump to content
Corsair Community

H70, getting very noisy


vlab

Recommended Posts

Hello !

 

I have a H70 cooling kit that used to work very well,

now for a few days, I have this buzzing sound that appeared, and won't leave. (very annoying BTW, it's louder than anything else in the room...)

 

It's steady, sound like electrical buzzing, or like some say "cable stucked in a fan". the typical noise that seems so common for H-series owners.

 

It used to work perfectly when connected to the CPU fan connector,

I tried connecting it to the CHASSIS fan connector, no improvements.

 

I also tried running the computer tower on its side for some hours,

no improvement either,

 

Leads me to believe that my H70 pump is dying...unless there is a solution that does not imply RMA? I checked on the forum and everyhere, and I haven't found anything else than what I've already tried.

 

My CPU is a I7 970, non-overclocked, and I noticed that since that grinding noise appears, my temps were significantly higher (though still safe I guess)

before, I was idling at 27-29c, now I'm at the highest 30's C.

 

I was wondering if there is any ways to get an "advanced" RMA?

So I don't have downtime with the computer ? I would need it to work despite the noise, cheking my temps very closely,

 

Thanks for any help!

 

Cheers !

 

Vincent

Link to comment
Share on other sites

  • Corsair Employees
I was wondering if there is any ways to get an "advanced" RMA?

So I don't have downtime with the computer ? I would need it to work despite the noise, cheking my temps very closely,

 

You will need to call our customer service to set up an advance RMA. This is the only way we can handle this. Like what Toasted said, you can use Skype to call them and it'll be toll free.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...