Jump to content
Corsair Community

Corsair M90 overloading and freezing


inimical

Recommended Posts

Just want to say thanks for any help in advance,

 

I use my corsair M90 mainly for MMO gaming. The side buttons for my mouse seem to work completely fine however when things start to get a bit hectic and I'm having to spam buttons, the mouse buttons sometimes become completely unresponsive. For example, if I'm spamming say mouse button 8, and then need to quickly hit mouse button 12, mouse button 12 won't respond at all. After about 4-5 seconds it will start functioning again as normal but when PVPing in an MMO this is a problem that immediately can cause a loss. I absolutely love the feel of the M90 and have adapted entirely to its button layout which I think is phenomenal, but if the mouse can't keep up processing clicks I simply won't be able to use it. Shortly after I purchased the mouse I convinced a friend to purchase the same one, and he actually noticed the freezing problem right away and brought it to my attention. Since then I've noticed it is consistently happening. I'm wondering if anyone knows if this is simply a configuration issue, or if the mouse simply can't function or keep up in the way I want to use it? Creating a mouse with 15+ buttons makes me think it was designed specifically for MMOs, so I don't see why it wouldn't be able to keep up with button response, but maybe I'm wrong.

 

Has anyone else had this issue, or know of a way around it?

 

Cheers,

Marcel

Link to comment
Share on other sites

Inimical - not sure if this helps you but I had very similar issues to you & have fixed it (at least for me). Bought the M90 Mouse yesterday, got home & set it up for WOW. Went in and found that nothing was really happening as I expected - very much as you described with large delays & stuff just not happening. Yes I have latest firmware & software. I then tried it in notepad and clicked the 15 button then a number of times then the 10 button - lots of repeats and few seconds until other one show up.

 

I was using "Basic Options -> Basic Button -> keystroke" to bind all my keys. Tonight after reading around I tried replacing all these with with actual macros. (ie press MR to manually record a simple single key down/key up macro). This has worked perfectly for me - might be worth a shot ....

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...