Jump to content
Corsair Community

Cursor movement problem on M60


maxvp

Recommended Posts

Hello,

I recently purchased a M60 Vengeance mouse. On the first day everything was working like a charm, but on the second day the cursor was not moving anymore, the buttons were being recognized but no movement of the cursor at all.

I have update the firmare, installed the driver, done everything I could imagine, but none of them fixed it.

Then I tried changing my surface, then I realized that on a plastic surface the mouse moves only if I set the lift height to high.

My question is what is the problem with the mouse? On the first day was working on my wood desk now only in a plastic and High lift height setting.

Is there something else that I can do?

 

Thanks!

Link to comment
Share on other sites

Try a hard, dark surface.

 

"The Avago sensor found in the Vengeance M60 works best on a smooth, dark surface that is free of dust, dirt and oils."

Source: Vengeance M60 Software users manual.

 

Run the Surface Quality test with the plastic surface and see the results.

Link to comment
Share on other sites

Yesterday the wood desk gave me good result in the test, today only in the plastic surface I can get some result and it's as good as the wood yesterday (good at max!).

 

I have already tried with a black paper but still I don't get the cursor moving.

 

Thanks anyway.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...