Jump to content
Corsair Community

FAQ: Media Keys Do Not Work


Recommended Posts

If you're using Chrome and installed Google Music extension, then Chrome will hijack your media keys.

Either uninstall the extension or switch Chrome's access authority to media keys to "in chrome" versus "global"

 

Plex can also hijack these keys in Chrome.. just change from global to in Chrome.

Link to comment
Share on other sites

I'm having an issue with the media keys not behaving as expected. Although I've had my K70 for a while, I've never really used anything besides the Mute key and volume wheel until today, so I'm not sure if this is a recent issue or if it has always been like this.

 

Mute and volume wheel work correctly universally.

Stop works correctly only in VLC, otherwise does nothing.

Next track button triggers both next track and mute.

Previous track button does nothing.

Play/pause does nothing.

 

I've tested this in various media players (VLC, Windows Media Player, WinAmp, BSPlayer, Groove Music). When attempting to manually assign the buttons in VLC, VLC doesn't even recognize when I press the previous track or play/pause buttons. I do not have that Google Play Music extension installed.

 

Any thoughts/suggestions?

Link to comment
Share on other sites

  • 1 month later...
I had a similar issue, but mine was due the Plex Google Chrome extension that it seems Plex's website added. It completely took control of my media keys... what a pain in the ***. Hope that helps someone else. My trick to see what was going on was to view the list of extensions, then at the very bottom of the screen there was a "view hotkeys" clickable, doing so showed me all the various hotkey settings, and sure enough Plex was there taking over my media keys. Hope this helps someone else!

 

Thanks, fixed my issue.

Link to comment
Share on other sites

  • 1 month later...

I recently rebuilt my system and after struggling to remember how I had configured Winamp previously, I decided to post it here in case anyone else found it useful.

 

This is of course my opinion of "correct" but I do think this is the best configuration for usage of the media keys. The problem with the "out of the box" configuration is that the keyboard volume roller simultaneously changes both the Winamp and main system volume. This fixes that.

 

Setup is Windows 10 x64, Winamp 5.666, and the latest CUE. This should be valid at least back to Windows 8, and probably 7.

 

1. Make sure Winamp is either the only media player selected in CUE Settings, or else has Max Priority set.

 

2. Open Winamp and CTRL+P to open Preferences. Select "Global Hotkeys" from the tree on the left.

 

3. Disable the first tick box (Enable WM_APPCOMMAND messages).

 

4. Enable the second tick box. This activates the hotkey box below. Unless you intend to use them, remove the CTRL+ALT+X commands (you will otherwise get an error that some of them are already in use by the OS - this can be ignored either way).

 

5. Close the Preferences box and restart Winamp.

 

Resulting behavior: The volume roller on the K70 will now control the Windows system volume UNLESS Winamp has focus - in which case it will control the Winamp volume only. Mute will always be system-wide. The four media keys will continue to work regardless of what app has focus.

 

I hope someone finds this useful. I'm also sure this would work for any other CUE-supported keyboard.

  • Confused 1
Link to comment
Share on other sites

  • 2 weeks later...
  • 8 months later...
  • 2 months later...

Hey, hello there. Just bought my first mechanical keyboard yesterday. Love it so far.

 

 

Anyways, I use this thing at work and spend a decent amount of time with a remote desktop on another screen with music playing on my local machine. I have noticed that when focused on the remote desktop, the play, pause and track controls do not work. Is there any way to fix this? I did not have this issue with my logitech k800.

 

K70 RGB Lux with CUE 2.6.70

Link to comment
Share on other sites

  • 3 weeks later...

My media buttons on my K70 RGB has stopped working. It only works if I have Spotify as the active window. When I change to Chrome, a game etc, it doesn't work anymore. What gives?

 

I have the latest FW, and I did check that the correct service was running.

Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...
  • 3 weeks later...
  • 2 months later...

Hi there.

 

I have just gotten myself a K65 Rapidfire. (I was using Strafe RGB previously)

 

Downloaded the latest CUE and started running it.

 

However, the volume keys, mute key and windows lock button aren't working. I don't have this issue with the FN Media keys, and previously it works well with my strafe. I have no Google Play Music or Winamp. I don't think it's a hardware issue. I have also restarted and switch HID services on, and set it to automatic startup at the same time. Restarted my computer, reinstalled CUE a few times. Still doesn't work.

 

Anyone has any idea how I can get the keys to work?

 

Thank you!

Link to comment
Share on other sites

  • 3 months later...
I just solved the problem by shifting the switch right next to the keyboard cord from BIOS to 1. Hope this helps.

 

Legend... Like honestly I moved it the other day and some how was able to switch it to 4th option without realizing, making me a little annoyed hahaha. thanks for pointing it out

Link to comment
Share on other sites

If you're using Chrome and installed Google Music extension, then Chrome will hijack your media keys.

Either uninstall the extension or switch Chrome's access authority to media keys to "in chrome" versus "global"

 

Thank you this is fixed me.

Link to comment
Share on other sites

  • 1 year later...
  • 1 year later...
  • 3 months later...

k65 all top keys not working at all i.e. mute, vol, windows lock key..

 

Tried all bios modes.

Tried with cue not running.

HID services running.

Dont have chrome. Using Firefox.

 

key lights are still working but nothing happens when i press them.

Edited by isupply
Link to comment
Share on other sites

I appear to be having the same issue as everyone else.

 

I don't have the google play or plex extensions installed, Human interface is set to automatic, have tried 8,4,2,1,Bios settings on my keyborad and still nothing. Also my board doesn't show up in iCue, i am assuming it is too old. M/N Vengeance K70

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...