Jump to content
Corsair Community

H100i Manual/Quick Start Guide


AlphaBravo

Recommended Posts

  • Corsair Employees
The installation is very similar to the old H100/H80 series, except for the retention bracket that is much easier now to install because it is just magnetic attachment to the pump. The thumbscrews, backplate, and the rest are the exact same thing.
Link to comment
Share on other sites

How long is the cable that plugs into the USB motherboard header?

 

 

Do both fans have to be plugged into the single cable that is included with the unit and or can they be plugged directly into the pump unit?

 

There's a special cable that plugs into the pump. The other end of this cable has two standard 3-pin fan connectors. You attach the two fans to these connectors.

 

There are two of these special cables so that you can attach a total of four fans to the pump (two that come with the unit and two others that you have to buy).

 

@Corsair,

These are the kind of questions that can be easily answered if one could download the manual. Other manufacturers do this this and there's no reason for Corsair not to do this. It's not as if there's anything to hide - is there ?

 

I too was looking for the manual before I bought the H100i and could not find anything. Eventually ended up looking at youtube videos trying find out how to install. But even those videos cannot answer all the questions.

Link to comment
Share on other sites

  • 1 month later...

Well, one month and one day later?

I can't find an online manual for the H100i, either.

 

My new H100i arrives in two days. I just wanted to get a head start on things.

I knew ahead of time, that there have been some problems, I bought it anyway based

upon Corsair's reputation.

 

Come on Corsair, it's darn near negligent to not have an online manual.

Further, having a "sticky" on install procedures/pitfalls to avoid on the "i" series would be quite comforting to us "noobs". I believe you have a good product. I just wonder if the problems are because of end user installation? Thank You.

Link to comment
Share on other sites

I guess this would be a good place to put this.

 

I did some searching on the forums but didn't see anything about this. Has anyone mentioned that the H100i instructions contradict themselves in terms of what standoffs to use?

 

Page 3 says "Use H for LGA 1155/1156, and G for LGA 2011" but this contradicts what is shown in the parts list and the graphic on that page.

Link to comment
Share on other sites

My last post in this thread was on the 5th, five days ago.

How long does it take to PDF the manual and post a "sticky" on this forum?

 

I have had an H100i for the last few days. I really like everything about it, except, it won't accurately allow any program, to include Corsair Link to display the CPU TEMPS.

 

I bought this unit to overclock my CPU. How can you do that, not accurately knowing your temps?

 

I strongly suspect, it's a USB problem, only affecting a few. When my fan controller gets here tomorrow, that should solve the problem. Along, with removing the USB cable from the pump unit and fans.

 

Not a deal breaker to me at all. The H100i, itself, works great.

The software/hardware "hook up"...maybe, not so well.

 

It really just baffles me that a H100i Install "sticky" doesn't exist.

Seriously, I cared enough to buy the product.

Do y'all care enough?

To fully support it? Whether you get the glitches fixed or not? I'm gonna buy another one for my wife's computer, it's that good. (Potentially)

Link to comment
Share on other sites

Yes I confirm that the fans do NOT have the directional arrows embossed on the fan housing on my H100i. Either a manufacturing fault; rushed product release where they forgot to add the arrows; or an error in the manual.

 

But there are threads on this forum which discuss the airflow directions so that you can install the fans correctly.

Link to comment
Share on other sites

  • 4 months later...

My son's motherboard recently needed to be replaced and he has have taken it into a shop to have the whole system put back together. However, they have no way of knowing how to put the cooler back in and he no longer has the instructions that came with his cooler

 

If anyone can send me a scan of the original instructions that would be a start!

 

Thanks in anticipation

 

Chrissy

Link to comment
Share on other sites

My son's motherboard recently needed to be replaced and he has have taken it into a shop to have the whole system put back together. However, they have no way of knowing how to put the cooler back in and he no longer has the instructions that came with his cooler

 

If anyone can send me a scan of the original instructions that would be a start!

 

Thanks in anticipation

 

Chrissy

 

if the shop cant install this cooler,quite frankly id be concerned about his computer skill as they arent that hard.

 

http://www.corsair.com/us/media/cms/manual/49-000175_rev_AB_H100i_QSG_web.pdf

guide can be found in the item product info.

Link to comment
Share on other sites

if the shop cant install this cooler,quite frankly id be concerned about his computer skill as they arent that hard.

 

http://www.corsair.com/us/media/cms/manual/49-000175_rev_AB_H100i_QSG_web.pdf

guide can be found in the item product info.

 

Really??? I havent a clue personally, but I will pass that on to my son. Thank so very much for your help, very much appreciated :)

 

Chrissy

Link to comment
Share on other sites

  • 5 months later...

I dont know what is going on, but there are a lot of things that are wrong

with the Corsair products I have been buying. The manual that came

with the H100i gave me a lot of problems until I called cust svc

and they told me my 1150 was the same as the 1155. It was very

confusing. My CPU only has one wire, not the three it should have

so my sensors for my CPU read nothing. My bios says CPU fan control

error every time I boot up.

 

My new 650D case was old too, the new ones are suppose to

have some sort of thing for the front to install a rad in the front

and mine must be old stock, as it did not come with that configuration.

I read it somewhere, but now its been weeks and I dont remember just

where. I just searched the forums but did not see it.

 

I just remember it had to do with the front Fan and standoffs or

some type of mount that I did not receive.

 

I guess new egg had a lot of old stock on hand.

 

I love my new rig.....

 

Corsair Obsidian 650D case

Intel i7-4770K 3.5 OC'ed to 4.422

Asus Maximus VI Formula Motherboard

GSkill 2400 speed Ram, 16 Gigs

Corsair H100i cpu water cooler

Corsair 1050 watt PSU

Intel 520 series 120 gb SSD

Kingston Hyper 120gb SSD

WB Velociraptor 70 gb HD 10,000 rpm

Seagate 2tb hybrid ssd/reg Hard drive

Sony DVD read/write 40 speed

Logitech YUY-95 illuminated keyboard

Corsair M-60 mouse

Razor Nostromo mini keyboard

Creative Labs 7.1 T7700 speaker system

Cyber Power 850 AVR voltage regulator and power backup

Three Dell 24" monitors on one stand in Horizontal configuration

OS= Win 8.1 Pro 64 bit

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...