Jump to content
Corsair Community

Low IOPS With Force 3 120 GB


Sycobob

Recommended Posts

I've been playing with this for the better part of two days and I can't seem to figure out what's up with my SSD. I replaced my CPU and had some problems with Windows, so I reinstalled. When I did, SSD performance dropped significantly. WEI used to rate it at 7.9 and now it's at 7.6. CrystalDiskMark scores have dropped as well, *especially* 4k reads (half of their previous value). I was almost ready to deal with it, then I ran a couple of different benchmarks (Anvil and IOMeter) to measure IOPS and got dreadfully low numbers. Whereas the SSD is rated for up to 85k IOPS, I'm getting maximum 19k reads and 38k writes.

 

I've gone through a bunch of troubleshooting steps, so I'll just list what I've done:

 

Made sure drive on chipset controller

Made sure drive is in SATA 6Gb/s port

Made sure cable says SATA 6Gb/s and isn't kinked

Updated firmware to 5.03 (+10% write speeds)

Checked drive state/health in CrystalDiskInfo

Installed chipset drivers

Made sure AHCI is enabled (+10% read & write, used msahci and AMD's driver)

Check partition alignment

Backed up Windows, secure erased from Parted Magic, restored with Acronis (+20% write)

Poked around in the BIOS. Disabled C1E, CPU power phasing, and AMD Cool 'n' Quiet

 

At this point, I'm at a loss. I have no idea why my drive isn't preforming properly. I'm still getting awful 4k reads and IOPS.

 

Here are some of the current results from various benchmarking utilities and some comparisons:

 

CrystalDiskMark Random Fill_______________________________0x0 Fill

http://i.imgur.com/tEQXN.pnghttp://i.imgur.com/Ssijy.png

 

What I'm comparing to:

Older 0x0 Fill

http://i.imgur.com/1zzUc.jpg

 

Review: http://thessdreview.com/our-reviews/corsair-force-series-3-120-gb-ssd-sata-3-review-atto-disk-benchmark-crystal-diskmark-and-as-ssd/

 

ATTO, as seems to be preferred here:

http://i.imgur.com/VHA2Y.png

 

IOMeter:

http://i.imgur.com/cLuzw.png

 

What I'm comparing to: http://www.guru3d.com/articles_pages/corsair_force_3_120gb_ssd_review,11.html

 

Anvil:

http://i.imgur.com/W0DIF.png

 

Other comparison: http://www.storagereview.com/corsair_force_series_3_review

 

CrystalDiskInfo:

http://i.imgur.com/xz6wU.png

Link to comment
Share on other sites

I've run with 15s as well. It only controls how often the results refresh and not the value of the results. It's still measured in I/Os per second.

 

I have never seen your second statement anywhere else. In fact, I read an article by Corsair themselves where they benchmarked a drive nonstop until it failed completely and never saw any performance drop. Do you have a source?

Link to comment
Share on other sites

Here,

http://forum.corsair.com/v2/showpost.php?p=468735&postcount=17

 

The post is fairly old now so i'm not really sure if the newer drives are affected by it.

 

The results from the reviews may have been from a clean empty drive.

 

The ATTO results look alright. But if you are not satisfied with it you can secure erase the drive with Parted Magic and install a clean version of Windows.

Link to comment
Share on other sites

Thanks for the follow up. Here is the article I mentioned. They started with a fresh, empty drive and basically ran it until it died. They wrote 240 TB continuously until the controller gave out and saw no performance drop. Also, I noticed the performance drop as soon as I reinstalled Windows and ran WEI, so I hadn't been running lots of benchmarks when it happened.

 

I did perform a secure erase, as I mentioned. I did it sort of weird though. I reinstalled Windows, backed up (not sector by sector), secure erased, then restored my backup. I followed the sticky in this forum and I did notice a significant change in speed.

 

At this point my speeds aren't terrible, but I'm getting a huge loss of 35% on 4K reads, which is the most important one. And the fact that IOPS is nowhere near what it should be really bothers me.

Link to comment
Share on other sites

The Blog entry was submitted by a user on the forum. It isn't really Corsair's themselves that did it.

 

WEI is should not to be treated as a benchmark tool. It changes over time so you may get 7.9 one time and 7.8 another. It is not an indication that the drive is slowing down.

 

If the drive has an OS installed, It is normal for the results to be a little lower as you have vital services that are running. Most SSD reviews and results are usually benchmarked when the drive is empty.

 

Also take note that the results can vary between different chipsets and platforms.

Link to comment
Share on other sites

True, trying to compare directly to someone else's benchmarks on a different system is a rough idea at best.

 

However, I'm comparing my own scores directly before and after a Windows reinstall. Before I reinstalled I ran WEI, Crystal, and Passmark's Performance Test. All showed decreases in performance. Same version of Windows, only the CPU changed. That indicates an actual change in performance.

 

Further, even though one can't expect to match exact benchmarks published by others, it provides a ballpark for near ideal circumstances. The fact that I'm getting ~50% of expected IOPS indicates there's a problem. This is what I'm trying to find.

Link to comment
Share on other sites

I've tried going back to the MS-AHCI driver twice. Benchmarks are almost identical (about 5% slower on MS-AHCI). I was actually using the MS-AHCI driver when I noticed the issue and only switched to the AMD one when I was trying to fix the problem.
Link to comment
Share on other sites

  • 3 weeks later...
  • Corsair Employees
I am sorry I don't see any real issue here so I am not sure what you want us to say. I would suggest reading back through the replies in this thread as that is the best answer we can give you at this time. If you really want to be sure test the drive on an Intel Sandy Bridge system with ATTO and I am sure you will se the rated speeds.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...