Jump to content
Corsair Community

Corsair Flash Voyager GT USB 3.0 32GB not working on a USB 3.0 port under Windows 8


Nerph

Recommended Posts

Hello,

 

When Windows 8 first released, I upgraded my laptop with Windows 7 Ultimate 64-bit to Windows 8 Pro 64-bit. Now, under Windows 7 my Corsair Flash Voyager GT USB 3.0 32GB worked fine in the USB 3.0 port I have on my laptop, however under Windows 8 Pro 64-bit it does not work, I get the following error:

 

"USB Device last connected to the computer has malfunctioned and Windows does not recognize it"

 

Now I've contacted both Acer and Microsoft about the issue, Acer told me to contact Microsoft, Microsoft told me to contact Corsair, so here I am.

 

Is this a known issue, as I find it strange it works under Windows 7 but not Windows 8 (again, in the USB 3.0 port, in my USB 2.0 ports it works under both OS's), or could it be a driver issue (so I need to contact Acer again)?

 

Kind Regards,

 

Andreas "Nerph" Ball

Link to comment
Share on other sites

  • Corsair Employees
I am sorry but you are not going to like my answer, but if you search the forums you will see this is a common problem with Windows 8 and the System Manufacturer will have to release a BIOS or driver update to solve that. The fact the drive works properly on that system with Windows 7 would confirm that it is a driver issue in Windows 8.
Link to comment
Share on other sites

Looking on their drivers page there isn't anything new (there was never anything for USB there, only stuff like audio and video card drivers) since I last checked, except a BIOS update. I've gone and flashed my BIOS and installed the latest version, I'm going to try and see if I can find out the "changes" in that latest version.

 

I can tell you from Device Manager that the USB Host Controller used is "Renesas Electronics USB 3.0 Host Controller" (there is also under that an entry called "Renesas Electronics USB 3.0 Root Hub"). I guess I should maybe search the internet a bit and see if others who use that host controller, and Windows 8, have suffered the same issue?

 

edit: I found this link: http://www.tomshardware.com/forum/1213-73-windows-renesas

 

Someone with pretty much the same problem, however there are mixed replies in that topic, for some updating to Windows 8 gave them no issues with their USB 3.0, and for others it did. One person mentions opening up his PC to check the PCI-e addon conntroller and finding the label for it, but I can't really do that on a laptop without voiding my warranty.

 

Kind Regards

 

Andreas

 

update: I managed to get my Corsair USB 3.0 flash drive working under Windows 8, finally! Just reinstalled the Windows 7 Renesas drivers from my laptop suppliers site in Windows 7 Compatability mode and now it works :)

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...