Jump to content
Corsair Community

Corsair M60 mouse - only basic buttons work


doscape

Recommended Posts

I've updated the firmware (to the latest before installing Corsair software),

here's the info pasted from the software:

Software: 1.00.00.27

USB Mouse:

VID: 0x1B1C

PID: 0x1B30

Manufacturer: Corsair

Product: Corsair M60 Mouse

Firmware: 3.01

Windows: Windows 7 Ultimate 64 bit

 

The problem is:

Forward/Back/DPI buttons don't do anything, no response at all.

Do I have a faulty unit? I already tried several computers + install/reinstall of the software. (btw, tried to re-update the firmware but it just said USB port is open on 2 different systems and connected directly to the back io panel)

Link to comment
Share on other sites

What did the FW updater say? Copy+Paste it here.

Do you have any other drivers / software installed for any other device? e.g. Gaming mouse software, wireless mouse.

If so, Uninstall it and check the information screen again and look if the FW is read correctly.

Does the information screen show the same thing as above?

Latest BIOS and chipset drivers?

Link to comment
Share on other sites

it says in firmware ver: NA

Dude, why didn't you give me this link from the beginning???

I've fixed it.. stupid corsair, you have to give proper directions for users before they install new firmware (incl. pictures for noobs)

and give this guy a present, new headphones or something

aaaaaaaaaaaaaaaaaaaaaaaaaaggggggggggggggggggggggggggh!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...