Jump to content
Corsair Community

where to download firmware


richied

Recommended Posts

Hi first post.

as with many of the posters I have problems getting this up and running.

 

currently have version 2.20 which runs and finds the processor temps (over USB Link?) which are approx right. The 3 HD's are found but are approx twice the actual temps, and my Video card is correctly identified with the correct temp.

I see no H100, no Commander, no cooling node, and therefore no fans or additional sensors.

 

From the many posts I have read it seems having the right firmware is important.

Unfortunately as the commander does not find the cooling node, nor my H100 I don't get to be able to download the firmware the normal way,or to see what firmware I am running.

Is there a direct link to the current firmware.

 

Many thanks for suggestions.

 

Richie

Link to comment
Share on other sites

If you want to use LINK 2, The Commander FW needs to be on FW 2.0.6.

 

Note: If you currently have a Corsair Link Cooling/Cooling and Lighting Kit and are running the 1.2.7 V1 software you will need to update your Corsair Commander unit with new firmware in order to be able to use your current hardware with the new V2 software. Once you have updated your Commander unit from the current firmware to the new firmware you will not be able to re-flash to the old firmware. You will need to install the new V2 software on your system and use it to flash this firmware file to your Corsair Link Commander unit.

 

Download Corsair Commander Firmware Version 2.0.6 here. Unzip before flashing

Link to comment
Share on other sites

many thanks Toasted

 

Did a complete install.

Unfortunately still no further.

Tried different USB headers. One did not light up the green light on the Commander. Here Sierra did not crash, but allowed me to go through the Firmware update, recognising both the commanter and a H100i/H80ibut could not update the firmware.

As soon as I tried another Header, and the green light came on sierra crashed.

 

I will try other combinations when I am free.

 

Richie

Link to comment
Share on other sites

The green light as in the Commander Unit power L.E.D.?

If so, The header on the motherboard that did not power the Commander unit may be faulty.

 

Do you have the latest BIOS installed in case it fixes this issue?

Have you tried resetting the BIOS to default settings by shorting the pins or removing the CMOS battery.

 

Is the Commander unit on FW 2.0.6 yet?

If not, Uninstall LINK 2 and install LINK 1.2.7 and update the firmware.

Note: Your H80i/H100i will not be detected under LINK 1.2.7.

Link to comment
Share on other sites

@Toasted, Thanks for the suggestion.

 

I got help from the Tech Guys.

 

Delete Commander 2.20, install 2.11, flash LC with 2.06. This worked, now everything is recognised.

However H100 seems to be still not right. I probably need to update the firmware on both this and the cooling node.

 

Does anyone one have links to the latest Firmware for the cooling node and the H100?

 

Richie

Link to comment
Share on other sites

@Toasted

 

The H100 shows 4 Values 2x Temp 2x Power

 

They are not very stable (Value 0-340 wildly fluctuating) flashing Red.

 

Still this is already a vast improvement.

 

Currently Commander is on 2.06 and runs.

Cooling node is recognised as are sensors on CN. However Fans work with strange revs (24000)

H100 is recognised but values fluctuate

 

will update cooling node and if possible H100

 

Richie

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...