Jump to content
Corsair Community

K90 Backlight Stopped Working after firmware update


ip161

Recommended Posts

Hi, ive performed a firmware update today to 1.19 (i think) to be able to configure my macros.

After the installation the LEDs stopped working. the only lights still on is the white one (capslock, numlock...)

i tried reconnecting the keyboard multiple times to different USB slots. making sure both working. and they do.

Restarted the computer.

Nothing seems to be working. Obviously the lights are still alive. but the light intensity button does not seem to turn them on. even on the profile manager software u can adjust the brightness. it changes from 0-33-66-100 but nothing changes.

Please advice. Thanks

 

"update" the windows lock button doesnt work either. start button remains unlocked. neither do the sound buttons and volume control

"update2" when going in the keyboard configurator and pressing the i button it says

Software: 1.00.00.30

USB Keyboard:

VID: 0x1B1C

PID: 0x1B02

Manufacturer: Corsair

Product: Corsair Vengeance K90 Keyboard

Firmware: NA

Windows: Windows 7 Ultimate 64 bit

"update3" Trying to perform the firmware again: Get flash memory information failed!.

 

i now tried everything i can think of..

Please help!

Link to comment
Share on other sites

I fixed it by going back to previous version using these instructions http://forum.corsair.com/v3/showthread.php?t=104856

Its a shame to see the technicians say send it back to RMA when the solution is relatively simple.

Didnt follow all the instructions. missed some steps out. but now it works on a previous Firmware. And all happy.

Thanks to LordLobo

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...