Jump to content
Corsair Community

Strange problem with Accelerator


Wendigo

Recommended Posts

Hi everyone,

 

I have a problem using an Accelerator 45GB cache SSD. I've installed it about six months ago and it works fine except for one thing. When I download torrent files, there's always a lot of data corruption occuring (the file fails the last check when the download is completed, with sometime up to 50% of the data failing the hash check). This problem only happens if I save the data to the cached drive. Saving it to another non-cached HDD that I have in the system don't show the issue. If I desinstall Dataplex, the data download and save just fine on the drive that was cached before.

 

I've try updating to the latest version of Dataplex software (1.2.0.4) and the latest firmware (5.03), but still have the same problem.

 

So, the corruption problem only appears when I download a torrent file and save it to a cached drive. Everything else works fine, system is snappy with the SSD, and I don't see any other data corruption.

 

Do you have any idea of what may be wrong ? As anyone experimented the same issue saving torrent files on a cached HDD ?

Link to comment
Share on other sites

  • Corsair Employees
I have not seen a problem with this application before but we will pass it on to Dataplex to see if they have any information. I would maybe try and use another cable on the drive and maybe try it connected to another port.
Link to comment
Share on other sites

  • 3 weeks later...

Just to make a follow up on this issue. It's probably not a Dataplex problem but the SSD that's failing.

 

In the last few days, the system started to hang for 30sec to 2min. Was the working properly for maybe 10 min. then hangs again. Then, yesterday, Dataplex gave me this error message:

 

Dataplex error: Your cache drive is reporting errors and may need to be replaced.

 

So, I asked for an RMA and the drive will be on its way soon to Corsair.

Link to comment
Share on other sites

Uninstall Dataplex

Then secure erase the SSD with parted magic and reinstall Dataplex. See if the computer still hangs.

 

The secure erase is about the only thing I haven't try. I will do this and come back to tell you what happens. Anyway, it's not a bad idea to wipe the disk before sending it to Corsair.

 

Here are the things I've try to date:

 

Uninstall/reinstall Dataplex (before and after each of the following change)

Update firmware

Update chipset driver

Set the system to IDE or AHCI mode

Try changing SATA ports

Use MS or AMD AHCI driver

 

In any of these situations, the sytem works fine without SSD caching. As soon as I activate the cache, the problems start: file corruption (mostly happens with big files), system hangs, error message from Dataplex...

 

I also try to plug the SSD in the Gigabyte SATA2 port but, for whatever reason, Dataplex don't see the drive when plugged into these. I can see it in the BIOS but not in Windows.

Link to comment
Share on other sites

Uninstall Dataplex

Then secure erase the SSD with parted magic and reinstall Dataplex. See if the computer still hangs.

 

Many thanks! It seems it solved the problem. I've used "Wipe Disk" from Easus Partition Master, reboot the system and then reinstall Dataplex. Reboot again and the system doesn't hang anymore! I keep my fingers crossed and will wait a few days before sending it to Corsair. If everything keeps running smooth, I will just canceled the RMA and keep the drive as it is.

 

Thanks again! :biggrin:

Link to comment
Share on other sites

OK, bad news, the system hangs again...

 

Anyway, here is the Atto benchmark:

http://imageshack.us/a/img40/8349/attol.png

 

The read speeds are fine but there's definetely something wrong with the write speed. The 4.0 and 8.0 are almost stalled, at 4-5 MB/sec. Maybe it's related to the stalling problem...

 

Now, just after I had taken the screenshot, the system hanged for maybe 2 min. and I got the following error message:

http://imageshack.us/a/img825/5599/dataplexerror.png

 

Looking at the Dataplex status:

http://imageshack.us/a/img705/1409/dataplexstatus.png

 

After that, all hell broke loose. I had the reboot the system but got a blank screen instead of the login screen. Reboot gain, CTRL-D to disable Dataplex, but still going no farther than the blank screen. CHKDSK find that many files were corrupted. I had to format the drive and reinstall Windows...

 

So, it's still not clear if the problem comes from Dataplex, the SDD, or both. Maybe I will send the drive to RMA, but it will not solve anythning if the problem is Dataplex.

 

And to add to the frustration, the Dataplex product key is now locked since, obviously, it wasn't uninstall from the trashed installation!

Link to comment
Share on other sites

  • 4 weeks later...

Just a follow up on this issue.

 

I just got my replacement drive today. It was a nice surprise since I got a mint 60GB one. I was expecting a refurbished 45GB. So, two tumbs up for Corsair RMA service!

 

Now, the system works fine, without freezing or error messages. It now is quite responsive and smooth.

 

I've run an Atto benchmark and here's the results:

 

http://img594.imageshack.us/img594/3628/atto60gb.png

 

Now, the speeds just show a regular pattern, as expected. The slowest speeds are now faster, and the fastest speeds are stable once they reach the max speed.

 

So, thanks to all for your help!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...