Jump to content
  • Gaming Gear
  • Streaming Gear
  • PC Components
  • Gaming PCs
  • Software
  • Community
  • Support
  • Gaming Gear
  • Keyboards
  • Headsets
  • Mice
  • Mousepads
  • Chairs
  • Apparel | Gear
  • Accessories
  • Ambient Lighting
  • Streaming Gear
  • Capture
  • Stream Deck
  • Audio
  • Lighting
  • Green Screen
  • Multi Mount
  • PC Components
  • Cases
  • CPU Coolers
  • Fans
  • Memory
  • Power Supply Units
  • Custom Cooling
  • Storage
  • Thunderbolt Docks
  • Gaming PCs
  • CORSAIR ONE Gaming PCs
  • CORSAIR ONE Workstation Grade PCs
  • VENGEANCE Gaming PCs
  • iCUE Certified Gaming PCs
  • Visit Origin PC
  • Software
  • Download Software
  • iCUE Software
  • iCUE for macOS
  • Community
  • CORSAIR Gaming
  • Esports
  • Streamers
  • Students
  • Forum
  • Blog
  • Wallpapers
  • Press Room
  • Support
  • Download Software
  • Customer Support
  • FAQs
  • Warranty
  • Keyboards
  • All Keyboards
  • RGB Mechanical Gaming Keyboards
  • Wireless Keyboards
  • Headsets
  • All Headsets
  • Wireless Headsets
  • USB & Stereo Headsets
  • Mice
  • All Mice
  • Wireless Mice
  • Wired Mice
  • Cases
  • All Cases
  • iCUE Smart Cases
  • Mid-tower Cases
  • Full-tower Cases
  • Small Form Factor Cases
  • Power Supply Units
  • All Power Supply Units
  • iCUE-controlled PSUs
  • Premium Efficiency PSUs
  • CPU Coolers
  • CPU Coolers
  • iCUE Smart Coolers
  • 240mm AiO Coolers
  • 280mm AiO Coolers
  • CPU Air Coolers
  • Custom Cooling
  • All Liquid Cooling
  • All Hydro X Products
  • Design Your Loop
  • Fans
  • All Fans
  • RGB Fans
  • 120mm Fans
  • 140mm Fans
  • Storage
  • All Storage
  • M.2 SSDs
  • USB Flash Drives
  • Memory
  • All Memory
  • Performance RGB Memory
  • Performance Memory
  • Memory Finder
  • Thunderbolt Docks
  • All Thunderbolt Docks
  • Accessories
Corsair Community

Corsair BETA Link 2.X is not working


robandcathy

Recommended Posts

So I have not been here in a while, decided to try out the new beta, which for me went from bad to worse. I have zero control over any fans "even the corsair" one with my h300. I was abel to control 4 fans at one point, not anymore. only one cooling fan shows up out of 8 and I can not controll that one. Now come on guys were going on a year, with out fan control. Im about ready to throw in the towel and ask for a refund. Now after trying V2 I cant even go back to 1.2.7 ugh. :mad:
Link to comment
Share on other sites

Same here. Link is once again a piece of trash. It's taken my $350 power supply and put it on par of the quality of a $99 power supply. What an awful experience. You can't control half the things you could in v1. And they haven't updated the beta in months. I guess they know its also a failure and just gave up.
Link to comment
Share on other sites

I have to agree with bee144.... While a great idea, it's been executed all wrong! I'm removing my Link and flogging it on Ebay, I might get half of what I paid for it if I'm lucky..... Just had enough of products that say they'll do this, this and this, but don't deliver when in use.....
Link to comment
Share on other sites

sorry to hear about your misfortune withe the product.

i have it in two systems

the one i installed first was a huge problem child from the get go

the 2nd has performed perfectly

why when both units are the same?

after lots of experimenting i figured why the difference

my first one there was lots of changes made,versions changed,different trials and errors,like many i tryed making things work better and better

the problem i found was a thorough cleaning of link is needed in order for a clean install to work properly

i was ready to throw it in the trash but now it works as its supposed to

my problem wasnt the links but my own fault for clogging it up with too much link

Link to comment
Share on other sites

wytnyt I just installed the link for first time on a fresh install of windows, so nothing should be conflicting. Its bare minium at the moment and still nothing working right, not even the corsair fans! I cant justify spending money on new corsair fans when, when I purcahased it nowhere did it say "compatible with". Now I wouldnt spend the money on corsair fans either since they don't work as well, at least for me. I would think a year into the product some MAJOR progres would have been made. Maybe in the future Corsair should be specific in saying which fans the linke will work with befor people buy the product. I would have rather seen more fan controll then a nicer gui. The time spent on the GUI would have been better spent on fixing the fan controll issues.
Link to comment
Share on other sites

wytnyt I just installed the link for first time on a fresh install of windows, so nothing should be conflicting. Its bare minium at the moment and still nothing working right, not even the corsair fans! I cant justify spending money on new corsair fans when, when I purcahased it nowhere did it say "compatible with". Now I wouldnt spend the money on corsair fans either since they don't work as well, at least for me. I would think a year into the product some MAJOR progres would have been made. Maybe in the future Corsair should be specific in saying which fans the linke will work with befor people buy the product. I would have rather seen more fan controll then a nicer gui. The time spent on the GUI would have been better spent on fixing the fan controll issues.

 

in no way did i mean to imply this is what your doing but that i had and possibly offer another perspective on different problems.

i was ready to rma my unit and a total clean job was a last ditch effort that just happen to work for me

Link to comment
Share on other sites

in no way did i mean to imply this is what your doing but that i had and possibly offer another perspective on different problems.

i was ready to rma my unit and a total clean job was a last ditch effort that just happen to work for me

 

What did you do for your "clean" install? I'll try anything at this point.

Link to comment
Share on other sites

Im kinda confused what a clean install is. Th op say once v2 software and firmware is installed you can not go back. I just did a clean install of windows and then started right off with installing v2, dont think it could be much cleaner, but hey if you have a different method, please share. I do know that I was abel to controll more fans wth 1.2.7 then with v2, not even is my corsair cooling block being recognized.:confused:
Link to comment
Share on other sites

  • Corsair Employees

robandcathy

I am sorry you had trouble but did you post before on the make and model of fans you had installed?

And with 8 fans you would need to use 2 cooling nodes, I only see one or are you putting two fans using a splitter?

Have you tried the fans one at a time and or tried to unplug the Corsair Link from the USB and cycle the system on and off then reconnect the LINK?

 

Marz,

We release beta versions of the software to help provide the best possible software, you do not have to use the beta versions if you dont want to...

Link to comment
Share on other sites

What did you do for your "clean" install? I'll try anything at this point.

 

bee

before i added link to this system i had installed loads of programs such as asus suite,speedfan,realtemp,to just name a few.i tryed reinstalling link but same mixed results

i reinstalled windows to a cleaned drive and redid link.i havent went past link 1.25 as that works in both my builds

Link to comment
Share on other sites

robandcathy

I am sorry you had trouble but did you post before on the make and model of fans you had installed?

And with 8 fans you would need to use 2 cooling nodes, I only see one or are you putting two fans using a splitter?

Have you tried the fans one at a time and or tried to unplug the Corsair Link from the USB and cycle the system on and off then reconnect the LINK?

 

Marz,

We release beta versions of the software to help provide the best possible software, you do not have to use the beta versions if you dont want to...

 

I have 5 hooked up to the link and other 3 to MB, What I have NOT tried is to unplug the link and reboot, Ill give that a shot, but bad feeling it wont help.

Im also looking for 2 200mm fans that run quiet and work with the link, but did not see any that size offered by corsair as well as I STILL dont see extra lighting strips.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...