Jump to content
Corsair Community

Problem Corsair M90


mikahardware

Recommended Posts

Hello and excuse me for my bad english :)

 

I just installed a Corsair M90 and I have problems with ...

 

In games (Crysis2, Splinter Cell Conviction), only the keys 1,2,3,7 and 8 are recognized in these two games.

 

I created a profile 2 with assigning keyboard keys to mouse (with the red button MR).

 

Then, in managing profile, I appointed LED2 with profil2 and save on M90.

 

But when I select the profil2 to assign buttons on the mouse, is LED1 remains lit ... although the profil2 is loaded ...

 

And profil2 in games is not recognized except for the keys 1,2,3,7 and 8.

 

Could you please help me?

 

thank you

Link to comment
Share on other sites

Hi,

 

Software: 1.00.00.29

USB Mouse:

VID: 0x1B1C

PID: 0x1B31

Manufacturer: Corsair

Product: Corsair Vengeance M90 Mouse

Firmware: 1.11

Windows: Windows 7 Professional 64 bit

 

 

Hardware Playback is enabled and save the profiles to the M90.

 

I was able to assign keys in games (Assign buttons-> options button-> base-buttons> HIT).

 

But LEDs assigned to profiles do not work. Sometimes I LED1 lit, sometimes LED3 sometimes LED1 + LED6, ect ...

Link to comment
Share on other sites

Ok, So you have assigned the profiles to an L.E.D, saved it to the M90 and enabled hardware playback.

 

But the profiles are not changing when you change the L.E.Ds?

If yes,

Did you see the XXX% beside the Save to M90 button?

 

If not, Go to the M90 software main folder and double click M90Hid.exe and try again.

 

If that did not work,

 

Try reflashing the firmware for the M90

Try reinstalling the software.

Link to comment
Share on other sites

Sorry for the long delay. I've re-read the whole thread again a few times to get some kind of idea.

 

Do you mean you cannot change the profiles on the M90 when hardware playback is enabled?

 

Example 1; When you want to go to profile 2 to the assigned button does not work and the L.E.D stays on the first one and the second L.E.D. does not light up but profile 2 is functioning?

 

Example 2; The profile does not load, But the second L.E.D. is lit when you are trying to change profiles when hardware playback.

 

Example 3; The L.E.D. does not change and the profile is not loaded when you press the assigned Profile Up/Down button.

Link to comment
Share on other sites

mika on each profile set a button to profile select (doing this worked for me).

Make sure hardware playback is selected.

On the LED section make sure that you save the profiles to the mouse.

These are for the profile lights.

 

Also if you are having problems in game like I was turn off hardware playback and see if that works. Again worked for me.

Link to comment
Share on other sites

For example, the profile 2 is well recognized and switches over but the second LED does not light.

 

Can you try all 6 profile L.E.Ds and see if the L.E.Ds lights up on the other ones.

 

If the others light up, It may be a dead/faulty L.E.D. Contact your seller and ask if they can replace the M90 for you. If not, Request an RMA to replace the M90

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...