Jump to content
Corsair Community

Force GT 120 GB bricked by firmware 5.03


nick_dc

Recommended Posts

Hi.

I have a Asus G74SX laptop. Have been using Force GT 120Gb as a boot drive for about 6 month. With occasional freezes for 1 min or with complete lockups resulting in reboot/power out/battery out/wait/power back on/start. Other than these common issues it worked pretty good. I had it updated to 1.3.3.

Now I decided to update it to 5.03 hoping it would help get rid of lockups.

 

Did everything by PDF manual. AHCI on. Firmware update went successfully and showed new version in the Corsair_FieldUpdater_v1.1.exe. But after the first reboot I get a "Disk read error, press ctrl+alt+del to restart" error and can't get through it. The drive is seen by BIOS. The drive is seen and browsed by Acronis boot CD. The drive is accessible thru a USB-dock-station. Passes the CHKDSK, browsable. But still won't boot in laptop.

 

I reimaged it with Acronis to the state a minute before the firmware update. Didn't help. Same error. Still accessible everywhere else.

 

Any ideas?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...