Jump to content
Corsair Community

Laptop crashes after ~25 minutes when using battery power


sb8636

Recommended Posts

- 10 days ago I bought a 120gb Force GT.

- Replaced the old HDD in my 2-year-old Dell Studio 1458 laptop

- Installed newest firmware (5.0.3) successfully. Confirmed that AHCI is working (not IDE).

- Cleanly reinstalled the OS (Windows 7 Home Premium) then upgraded to Windows 7 Ultimate.

- Everything seems to be running fine, machine is faster, etc.

 

HOWEVER I have been having a huge problem - when I unplug my laptop from the AC adapter I am on battery (obviously).

 

Consistently since installing the Corsair SSD, after ~20-30 min on battery the laptop shuts down, without even a BSOD. It just goes black. This has happened at least five times.

 

If I try to start it back up on battery, the BIOS loads but just when Windows begins starting, everything goes black and it shuts down again.

 

If I plug the laptop into the AC Adapter, however, everything is fine and the computer starts up fine + runs indefinitely.

 

- I don't think this is a battery issue. I have tried this with two different batteries - my old one which worked just fine with my prior configuration and a new one I bought online. The crash happens in both instances.

 

- I don't think this is a temperature issue. I decided to use HW Monitor and took screenshots of temperatures every few minutes while running on battery. I've attached a pic of my desktop but the temps don't seem unreasonable.

 

- I've also attached the log report from Windows Startup Repair. Essentially it seems to be a crash (type 6.1.7600.16385) with no known root cause.

 

Does anyone have ideas/suggestions??

1459898341_Screenshot-9_9_201210_22_05AM.thumb.png.fcda333a5aac52f2885d2a04e7349713.png

759263775_smallercomputercrash.thumb.jpg.450bb8a9a1ef7fd8356ec3bc83997428.jpg

Link to comment
Share on other sites

Guest shan2129

1. I will suggest you run Windows Memory Diagnostics ( in Control Panel )

2. Check the Dell website, if they are offering any BIOS updates ( unlikely )

3. Make sure your SATA/AHCI drivers are properly installed ( update them if necessary )

4. Check disk alignment.

Link to comment
Share on other sites

Thanks for the suggestions.

 

1. Tried it but no memory problems found.

 

2. Tried it but seems I already have the latest BIOS for Studio 1458 (A07).

 

3. Tried it and successfully upgraded to the latest Intel Rapid Storage Driver (version 12.0).

 

I benchmarked with AS SSD and confirmed that the Intel driver (AHCI) is working. Using this driver instead of the Microsoft AHCI driver, my benchmark scores are significantly lower (140/161 read/write vs. 155/184 read/write) BUT my startup seems much snappier and programs seem faster in general vs. the Microsoft AHCI driver.

 

(Before, the AHCI driver on AS SSD said msahci = Microsoft driver; now it says iaStorA = Intel driver.)

 

I rebooted a few times and then unplugged the laptop; however, the laptop suddenly shut down - no BSOD just shut down - after 1-2 minutes of battery-powered use. This compares unfavorably to the past week under the Microsoft driver, when I would normally get 20-30 minutes of battery use before a crash.

 

4. I opened my laptop case, unscrewed the SSD, made sure it was all the way in the slot, screwed it back in, and closed the case. Again, successfully booted on battery-only and started Windows, but crashed after just 1 minute (vs. ~25 minutes on the Microsoft AHCI driver).

 

Any suggestions? I will let the laptop cool down completely then try again to see how long it lasts for on battery power, to make sure that the degradation in time definitely has to do with installing the Intel AHCI driver (Rapid Storage Technology).

Link to comment
Share on other sites

  • Corsair Employees

Look in the BIOS under power management ans see if its shutting off the HDD after a period of time when on battery if yes try and disable this in the BIOS.

I suspect the BIOS is not seeing it as an SSD and try's to put the SSD to sleep and then cannot wake it back up.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...