Jump to content
Corsair Community

[FIXED] Link not working


DarkHorse2728

Recommended Posts

I dont believe I am saying this, but Corsair you failed me. I am a Corsair *****, everything I have is Corsair.

 

Decide to buy the Link Controller and Light Kit. Installed it today. Doesnt work.

 

Doesnt change the CORSAIR AS120 fan RPM, doesnt change the LED LIGHTS, simply it is junk.

 

I have removed it from the system. Will probably throw it in the bin.

 

What a waste of time and $179.00 AUD. :mad:

 

Not Happy.

Link to comment
Share on other sites

Decide to buy the Link Controller and Light Kit. Installed it today. Doesnt work.

 

Doesnt change the CORSAIR AS120 fan RPM, doesnt change the LED LIGHTS

 

From the sounds of it I think you just installed it out of the box without doing any Software/Firmware upgrades which are needed especially to work with those fans. I wouldn't throw it away.

Link to comment
Share on other sites

I dont believe I am saying this, but Corsair you failed me. I am a Corsair *****, everything I have is Corsair.

 

Decide to buy the Link Controller and Light Kit. Installed it today. Doesnt work.

 

Doesnt change the CORSAIR AS120 fan RPM, doesnt change the LED LIGHTS, simply it is junk.

 

I have removed it from the system. Will probably throw it in the bin.

 

What a waste of time and $179.00 AUD. :mad:

 

Not Happy.

 

Yo, DarkHorse2728, give this company a chance to make things right, they have the best customer support team in the business. I bet you they make things right.;):

Link to comment
Share on other sites

  • Corsair Employees

Darkhorse2728,

I agree give it some time we are avidly developing this hardware and software.

You will as noted need the latest cooling node Firmware to support or SP and AP Fans. Version 1.2.5 But you will need to uninstall the current version of the software and update to Software Version 1.2.7 then you can update the Cooling Node Firmware.

I have posted Directions for these updates at the top of this section.

 

And before you ask the next version of our software uses a slightly different layout and has some other features for new hardware. But it is still Beta. If you would like to try it be my guest but you cannot go back easily to this version. I would suggest using this version and get familiar with the controls and then if you want to try the new version let me know.

Link to comment
Share on other sites

I dont believe I am saying this, but Corsair you failed me. I am a Corsair *****, everything I have is Corsair.

 

Decide to buy the Link Controller and Light Kit. Installed it today. Doesnt work.

 

Doesnt change the CORSAIR AS120 fan RPM, doesnt change the LED LIGHTS, simply it is junk.

 

I have removed it from the system. Will probably throw it in the bin.

 

What a waste of time and $179.00 AUD. :mad:

 

Not Happy.

personally i think you should give cl a little more time,i had lots of problems and most were due to my errors and not having the updated software

its a nice product,so much i just received my 2nd link today and plan on buying 2 more.

Link to comment
Share on other sites

Thank you for the replies guys. New mobo install, new H100 install (RMA to come) and new Corsair Link install.

 

I am afraid to re-install. Was getting constant restarts on new system and BSOD's. Uninstalled CL, removed 3 x sticks of ram, removed 2nd HDD and also removed the GTX690 and used intel 3000 graphics.

 

Computer seems to be running ok, no BSOD's, all Win7x64 updates installed, re-installed ram as well as GTX690.

 

I really do not want it to crash the system :[pouts:

 

Also what is with the molex connectors?? They are the spawn of Satan I am sure, wish there was nother connector Corsair could have used.

Link to comment
Share on other sites

Link should not crash your system, If it is stable now

 

Plug the Commander unit back in, but don't take too much time wiring the Nodes. Just open your side panel and plug the Commander in and the nodes.

 

Boot into Windows

Download Link 1.2.7 and the 1.2.5 Cooling Node firmware.

Install the dashboard and them check the firmware;

 

Commander Unit - 1.1.9

Cooling Node - 1.2.5

Lightning Node - 1.1.9

H100 - 1.1.12

 

I agree about the Molex connectors, They are a pain to install without a pin coming loose. But its commonly used in most products and the wiring is simple.

Link to comment
Share on other sites

G'Day Crew,

 

Thank you all for the replies and help, I really appreciate it. Computer has been running ok all day, so I decided to give the corsair link another shot.

 

After a few goes at getting the cooling node to upgrade it's firmware, I finally manged to get it to update and lo and behold it is ALL working well :biggrin:

 

I take it back about being a waste of $$$$. It is working as promised.

 

Again thank you.

 

Regards,

 

Rob

Link to comment
Share on other sites

Hi guys,

 

Thank you for the replies! I love to tweak and tinker, so having the CL just sitting there not working was annoying me, as I mentioned it took a few times for the upgrade to take, but it worked in the end.

 

I appreciate there are a million + combinations of hardware/software out there but some work needs to be done on the firmware upgrades somehow??

 

Revived a bricked M60 and finally the cooling node through persistance.

 

Thank you for amending my title to fixed :D:

 

http://i3.photobucket.com/albums/y77/737pilot/PC3.jpg

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...