Jump to content
Corsair Community

Hx620w shows current,but no potential


derekmro

Recommended Posts

shortly after a power outage I was shocked to find my computer unable to start up, no beep,no fans just a blinking light on my Asus p5k-e motherboard. Unsure of what was happening I checked the battery with my dmm. 2.9vdc, so I replaced it with a new one with 3.1vdc. No luck, I checked my power supply with my tester and it shows all ok. So with my dmm I checked each pin and they all show proper voltages. Now I cleared the mobo with the jumper pin and re tried start up, light on mobo stays solid green until I press power button and starts to flash,no fan,no lights,no action. I removed the psu and replaced with a spare and the system works like day 1. What could be dragging down this Hx620w?. ++=I have tried with the Hx620 to start just the mobo with out any other devices and no luck=++
Link to comment
Share on other sites

  • Corsair Employees
That sounds more like you had a power surge when the power went out. Are you using a surge suppressor? And assuming the PSU is still under warranty you can request an RMA and send it is but if its determined that it was damaged due to external reasons they will not replace it.
Link to comment
Share on other sites

The power outage was caused from me shutting off the wrong breaker when I was doing electrical work. After I was done working was when I had turned everything back on and noticed this problem. The cpu is on a surge protection outlet. Psu was purchased in Nov 2007 and should be covered under warranty?
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...