Jump to content
Corsair Community

issue


Tarpit

Recommended Posts

I dont understand. I almost finish installing the driver, but then it says i have to restart my computer. I restart the computer, but then i does nothing. My Acer aspire laptop also has a problem finding the headset itself when it is plugged in, so the headset dont make sounds at all. Can someone please help me with my issue? btw i run windows 7 64bit
Link to comment
Share on other sites

Seconding this.

 

I just received my vengeance 1500 in the post an immediately plugged them in. No sound

 

Windows says that this USB device has malfunctioned and drivers wont install automatically. So I downloaded and have attempted to install the 1.1 drivers and whenever I try to install I get to the stage where I have to connect the headset. I have tried to connect it with and without reboot and it just wont recognize it at all. The installation then fails at this stage.

 

I have reinstalled motherboard chipset and audio drivers and the headset lights up when I connected it to USB and I have tried multiple USB ports all of which work for my wireless network adapter and other USB devices and they fail to work.

 

Using windows 7 64 pro OS.

 

What am I doing wrong?

Link to comment
Share on other sites

For me it shows up as an "unknown device" in the manager

 

Edit:

 

Just tried these on a different PC

 

Same issue, comes up as "unknown device" in the manager and gives me the "device has failed to install" stuff whenever I plug it in

 

Friends machine was running Windows 7 32 home premium

 

Faulty or not?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...