Jump to content
Corsair Community

Help with GS800W


Thorr

Recommended Posts

This is more of a technical question but I thought I would throw it out there and see what everyone thinks. I don't profess to be very knowledgeable about PSU's so please excuse any incorrect terminology that I may use in my problem description.

 

I bought a new rig a few months back and it worked great for a bit. Problem was I went cheap with the PSU upfront (big mistake) and took the house brand that Cyberpowerpc offers. It's called ExtremeGear. As I should have known, the PSU crashed on me. Comp just went dead while browsing the interwebs and would not start at all. So, I decided to replace the ExtremeGear 750W PSU with a GS 800W PSU from Newegg. I run multiple Corsair products and all are flawless (Vengeance RAM, CPU cooler, mouse and SSD).

 

Got the first GS 800W and installed it and it worked for a week or so. Then the comp died. No power..would not turn on and no LED's had power on front of system. So I RMA'ed the GS 800W back to Newegg and got a new one. Installed the 2nd one and the system would not turn on. But this time I had a red LED light on my multicard reader that turned on. This made me think that the PSU may be good and my mobo might be fried.

 

I couldn't believe that I was having this many issues with PSU's so I ordered a Rosewill PSU tester from Newegg. Model RTK-PST. Once it arrived, I hooked up the GS 800W to it and it showed that the 5V channel was too low. It was fluxing between 4.2 and 4.5. Unfortunately I did not cycle through the LED's when testing. I only tested with the blue LED on because I did not realize it may make a difference (see below). This time, I RMA'ed the GS 800W back to Corsair for replacement. Also, I put the ExtremeGear PSU back in my comp and RMA'ed it to Cyberpower for warranty work. It is still there being fixed as I type this.

 

I just recently received the new GS 800W (3rd GS 800W unit and second unit tested on my PSU tester) and plugged it directly into my tester. Low and behold, it shows low voltage on the 5V channel and failed the PSU tester. But this time it fluxes a bit higher. Between 4.4 and 4.7. So, I'm thinking it's bad again and I have the worst luck in the world with PSU's.

 

On a whim, I decide to change the LED light from blue to off. Then I turned off the PSU and unplugged it from the tester. Later, I plugged it back in to double check it (still couldn't believe my luck) and it PASSED with flying colors (pun intended). In fact, the PSU tester showed it was almost perfect. So, while still hooked up to the PSU tester and powered on, I cycled through the LED colors and it failed again on red, white and blue. Same failure...5V channel was fluxing between 4.4 and 4.7. Then, with power still on, I cycle back to LED off and the tester shows perfect again.

 

I'm definitely not a PSU enthusiast or even decently knowledgeable reference PSU's so I ask the experts. Is this a known behavior of the GS 800W? Should turning on LED's cause the 5V channel to degrade? I know it's possible that my PSU tester is bad but why would it show the PSU perfect with LED's off and only show failure with LED's on? Finally, should I RMA this unit again and see if 4th times a charm or should I wait till my comp gets back from the shop and pop this in to test it inside the rig? I know that I am going to replace the ExtremeGear PSU that they will put in my system but I'm worried that if this GS 800W that I have now is defective, it might cause damage to my system. Thoughts?

 

All help is appreciated.

Link to comment
Share on other sites

It's been stated many times here in the forums that those PSU testers may not read correctly because of the components Corsair uses in their PSU's.

 

If you want to test it , start the PSU with a paperclip and use a multi0meter to read the voltages. This is the only way you will get a true reading of what your PSU is actually putting out.

 

I really think you have other issues with your system. A bad MB or something that is killing PSU's.

Link to comment
Share on other sites

  • Corsair Employees
The only way you can accurately test the out put from a PSU is under a load and every PSU I have seen will require a minimum load to give an accurate reading. I would try and connect an older spinning HDD and a few case fans to the Power leads on the PSU and test it again. Or plug it into the MB and turn the system on and go to BIOS setup and see what the Voltages show in BIOS.
Link to comment
Share on other sites

Thanks to both of you for the responses. I was honestly hoping that there was a reason that the PSU tester was not accurately testing. It just didn't make sense that I would have this bad of luck with PSU's. And I agree that there is probably something else wrong with my rig. Hopefully, the builder will replace the bad parts and send it back in tip-top shape (other than the terrible ExtremeGear psu they will install).

 

Question. If I use a paperclip to get my GS 800W running and check it with a multimeter, will I get true readings even though the PSU is not under load? Or do I need to also hook it up to a few old components (HDD and a couple fans) to accurately test it using a multimeter?

 

Again, thanks for the advice.

Link to comment
Share on other sites

  • 2 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...