Jump to content
Corsair Community

Recommend PSU


StuartMac

Recommended Posts

Hi,

 

I believe I need to replace my pc PSU - at least, it's died with the same symptoms as last time and last time a new PSU resurrected it.

 

The last two PSU's have been Another Brand (aiui I'm not allowed to say? but it's in my profile) and, given the other components were high-spec. (at least when the pc was built) and haven't died twice just after the end of the maker's warranty period, :mad: I'm not wildly keen on fitting a third PSU from the same maker.

 

I've been recommended to Corsair as a quality replacement. The info. on the Corsair website is somewhat ... uh ... overwhelming ... for someone who just uses a pc as a work tool and, on the PSU Product Finder, I can only fill in "Number of Hard Drives" ... :roll: So I'd really appreciate it if someone could point me in the right direction?

 

The PSU I want to replace says, "Total Power 550W" and "Peak 650W". Any help appreciated.

 

Regards,

Link to comment
Share on other sites

Can you look at your old one and see if there is a ATX specification on it. I believe your system would be too old for any of Corsairs PSU's.

 

It should say something like ATX2.0 or something similar.

 

[edit} Your system requires a -5v rail wich is an older ATX spec and most modern PSU's have done away with it. I am just about 100 percent sure Corsair will not have a PSU that will work with this MB. But please let RG confirm this for me to be sure.

Link to comment
Share on other sites

  • Corsair Employees
peanutz94 is correct I am sorry but our PSU would not be compatible with that MB. I am fairly sure you will need an ATX 1.3 P4 compliant PSU. And all of our PSU are ATX 2.1 to 2.3 specification.
Link to comment
Share on other sites

Hi guys,

 

Thanks for your help so far.

 

However, I might have inadvertently supplied some wrong information. :rolleyes: After reading peanutz94's post, I realised I'd supplied the first PSU's model number. The replacement (that's recently failed) is the same maker's ELT620AWT; according to the box, it's ATX12V v2.2. Also, its destructions specifically mention that it doesn't have a -5V rail, so I don't think my MB was ever using one.

 

The only thing I believe I don't need is the the second PSU's higher output - 620W total, 680W peak.

 

Any help?

 

Regards,

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...