Jump to content
Corsair Community

Vengeance 2000 Charging Cable Issue


Blobbers

Recommended Posts

Basically if I move a little bit in my seat windows plays the USB connect and disconnect sound so I assumed it was the new headset so I started messing with the cable a bit to find out if that was the cause and I believe that to be the problem. I have tested the headset on 2 Windows 7 machines and one Windows XP machine and I get the same results all leading back to the cable problem of it just disconnecting and reconnecting. The headset audio still plays fine its just the charging stops for a second and windows plays the USB sound and it reconnects its really annoying at times. Is there any way I can receive just a replacement cable?
Link to comment
Share on other sites

  • Corsair Employees

The Vengeance 2000 charging cable just supplies power to the headset. You shouldn't be getting any USB connect or disconnect sound because it should not be detected as a USB device.

 

That said, we don't have any spare cables at the moment. You can, however, use a different micro USB cable from any local electronics store as a substitute.

Link to comment
Share on other sites

  • 5 weeks later...

I am having the exact same problem as the O.P. The first time I plugged in the V2000 to the PC while it was turned on, it detected an unknown USB device and prompted to the driver instal wizard. The HS comes up as "HID-compliant consumer control device"

 

My guess is, if there is no lead from the LP+/- from the HS, then the ground or +5v lead are shorting out to the mini USBs LP+/-, unless it's used for firmware updates?

 

Either way, I can 100% confirm there is a connection being made from the HS, and turning left to right, does in fact, drop the HS connection from HID drop down in device manager.

Link to comment
Share on other sites

I just tried a different micro USB cable and it fixed the disconnect/reconnect issue.

 

I just bought the headset yesturday, and it wouldn't charge the headset, no light no anything.

 

I grabbed the cable for my phone (micro USB) and now it's charging. So bad cable in the package I guess?

Link to comment
Share on other sites

  • Corsair Employees
I just bought the headset yesturday, and it wouldn't charge the headset, no light no anything.

 

I grabbed the cable for my phone (micro USB) and now it's charging. So bad cable in the package I guess?

 

Sorry about that. Once we have spare cables up in stock, I can assist with you or anyone else that needs a replacement cable. You can use any micro-USB charger though for now to charge the headset.

Link to comment
Share on other sites

  • 2 weeks later...
  • 8 months later...

hi.

 

I have bought this headset and it started disconnect for no single reason for my use of it, it didnt last even 2 week and it refused to recharge. I tried to use another micro USB cable (and I shouldnt have to worry and do that to begin with), and for both only would it charge for EXACTLY 8 seconds.

 

I don't understand that.

 

Now I have put this headset to pieces, waiting in its original package to be thrown away

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...