Jump to content
Corsair Community

Brand new HX750W chirping?


venomblade

Recommended Posts

Alright I got my HX 750, set everything up, turn it on and now my HX 750 emits a constant electrical "chirping" it's a very noticeable sound, under no load at all, I've turned off all other fans, took out my GPU and tested without it, unplugged HDD as well, and it always, always makes that sound...I've tried different wall outlets, and some outlets seem to make less chirping then others, but upon further listening there's an always electrical noise going on. It sounds like it's coming from the very back of the psu.

 

I can put my ear to it from the outside back of my case and the noise is very clearly coming from my PSU. I can even hear chirping/crackling from the back of the PSU when the system is completely off. Not quite sure what to do now...I've just had to RMA another PSU(not corsair)because under heavy loud it would emit a nasty electrical sound, nowhere near the same sound as what I'm hearing now, but it just seems I have no luck with PSUs and I'd kind of like to avoid RMA'ing again.

 

I'm not sure if this could be related, but could it be because of a faulty outlet? Would getting a surge protector like this one do anything?

 

Also, I would like to note, after awhile it seems the sound goes away, but the fan still makes a noise, that I'm not sure if is a sound I'm supposed to be expecting. It's a constant whirring sound,and under that noise it sounds like a weak "whooping" sound which I'm not sure which sound is the fan blade. This is very frustrating because I'm not so good with words and it's really hard for me to describe what I'm hearing so you could get an accurate representation of what I'm hearing, but I just didn't expect this to happen day 1 using this PSU..

Link to comment
Share on other sites

Surge protector wont do anything for the noise. The PSU's circuitry already does the same thing.

Since this seems to happen across multiple PSU's i would check to make sure your outlet is properly grounded. And maybe try it on a completely different outlet that you know is on a different circuit

Link to comment
Share on other sites

Alright I'll try it on any and every outlet I can. Also a note, the previous psi that I rma'd( not corsair) only make nasty electrical noises under load after a month of use and that wasn't chirping, but more of an electrical scratching, so I'm not sure if it's bad outlets on my end, just rather bad luck...
Link to comment
Share on other sites

Alright I'll try it on any and every outlet I can. Also a note, the previous psi that I rma'd( not corsair) only make nasty electrical noises under load after a month of use and that wasn't chirping, but more of an electrical scratching, so I'm not sure if it's bad outlets on my end, just rather bad luck...

Either way, if you do isolate it to the PSU or just cant stand it:) you always have the option to have it replaced.

 

If you are still within your resellers time period for returns i would start there. If not, you can use the link on the left to request your RMA.

 

I'm not sure if it's bad outlets on my end, just rather bad luck...

LOL, yeah, I have one of those little black clouds over my head too! :)

 

Good Luck!

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...