Jump to content
Corsair Community

Corsair X128 problem


Recommended Posts

So I was working on my computer the other night & suddenly my PC locked up & I couldn't get Task Manager to open with 'Alt Ctrl Del'. Then a BSOD appeared, but it went to quick for me to get the code.

 

After it rebooted it got to the windows loading screen but very slowly & then produced another BSOD, again to quick for me to read.

 

I disconnected all my other hard drives & moved back down to one stick of 4gig, did a CMOS reset along with removing the battery too.

 

Then plugged my x128 back in, to which it is picked up sometimes by the starting BIOS & takes about 10mins for it to get to the next BIOS screen on my EVGA x58 m/b to then wait another 5-10mins then it will reboot. Error 75 is present on the EVGA LED de-bug screen -which means it is a hard drive related problem

 

I've connected my SSD up to a USB adaptor & plugged it into my laptop to see if I can transfer the data, as I desperately need to get the data for the past 4 days work, that I have done. But it loads up for an extremely long time in 'disk management' & shows it as being RAW data & that I need to format the drive to use it.

 

I've tried every possible way of trying to get the ssd to boot to windows to allow me to copy over my word documents that I so desperately need! Even tried to use this EaseUS data recovery program but it cant find my SSD when it is even showing up as Raw data in disk management.

 

I cant believe this is happening, as I was about to get 2 new Corsair Force SSD's (180Gb GT & 240Gb F3 N/book kit) in about 2 weeks, after I get my tax back & was going to upgrade my system.

 

Corsair or anyone is there any other way to get the data off? or should I just cut my losses & reformat the SSD, then open up an RMA process - as I dont want to be running my O/S on an SSD that has produced faults

Link to comment
Share on other sites

  • Corsair Employees
It sounds like the drive has just failed but to be sure I would try in another system as a second HDD and see if you can see the drive. You might also search for a utility to try and recover the lost file allocation table at http://www.snapfiles.com and see if you can recover your data. Short of that I would try Parted Magic and secure erase the drive to see if it brings it back to booting properly.
Link to comment
Share on other sites

So well Ive tried everything but just keep getting consistent BSOD's even when I've tried to access drive in each of the following, WinXp/Vista 64/Win7 64 & I still cant even access it. Not even to format.

 

Start up's seem to just lag on forever until I get please alt crtl del to restart, even when Im trying to boot from another hard disc.

 

Tried connecting it via USB, seems to lag for an extremely long time & wont allow me to format due to 'I/O error' which I got once after about 3 hours of trying

 

Tried recovery programs & they cant pick up the drive to access it for the data, which is disappointing.

 

What is wrong with the drive? Has it failed?

 

If I RMA it, will I get back an X128? Cause do you guys still produce them?

Link to comment
Share on other sites

The drive has probably failed.

 

Usually an RMA will replace your SSD with the same capacity and model of the faulty one. If they don't have any, You may receive a refurbished one or another model with the same capacity.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...