Jump to content
Corsair Community

k90 - media keys and volume control not working


Alti99

Recommended Posts

  • Corsair Employees

Click on the Windows Start Button and navigate to the Control Panel. Start up Administrative Tools and click on Services. Scroll down to Human Interface Device Access and ensure the service has started up. If it is not, click on restart the service to the left pane of the window and change it to startup automatically by double clicking the service.

 

Since it worked on another PC, it could just be the service needs to be restarted. Let me know the results.

Link to comment
Share on other sites

  • 2 years later...
This is a bit dated, so I apologize for bumping an old thread and again if this has already been addressed, but I'm having a similar problem with my K70 RGB. But, after following the instructions provided above, it will work. However, it only works when I have the services window open and in focus..I don't understand why that is and I can't find any solution to get my media controls working again. Please help me, thank you.
Link to comment
Share on other sites

  • 2 months later...
This is a bit dated, so I apologize for bumping an old thread and again if this has already been addressed, but I'm having a similar problem with my K70 RGB. But, after following the instructions provided above, it will work. However, it only works when I have the services window open and in focus..I don't understand why that is and I can't find any solution to get my media controls working again. Please help me, thank you.

 

 

 

I had exactly the same problem and my solution was to disable the Google Play Music extension in Google Chrome. You can also use this method if you want to keep Google Play Music. http://www.omgchrome.com/chrome-google-music-media-keys/

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...