Jump to content
Corsair Community

Data corruption after shutdown


Recommended Posts

Hello Everyone!

 

I have been trying to figure this one out for nearly two weeks and I was hoping I could get a fresh pair of virtual eyes on the subject. About a month ago I purchased six Corsair 3 Force 180 GB SSD's for a RAID 0 configuration. Everything was stable and fast; however, due to an OS issue (my fault) I needed to wipe the slate clean and reinstall windows. I figured the best way to do this was to use Parted Magic and perform a secure erase. So, that is what I did. One by one I performed this action without any difficulties. I re-created the RAID 0, re-installed Windows, and then the nightmare began.

 

Initially, everything was going well during the installation of Windows and my other applications. After a few hours and re-installing my applications I figured I would call it a night and shutdown the PC. The next day I powered on the PC to continue but I received a very disturbing message from Windows stating I did not shutdown properly. So I continued to load Windows and then scandisk ran automatically stating it needed to run a consistancy check. During this scan it found several errors on the raid array. It fixed them and I was allowed to continue. I figured maybe something happened during shutdown so I rebooted the system several times just to see if I could duplicate the error but I couldn't. So I shutdown and powered back up and then again more errors on the drive.

 

For some reason now every time I power down the PC there is corruption on the drives. I even tested the drives individually (installed windows on each drive) and was able to duplicate this issue. I figured this had to be a hardware problem so I pretty much swapped out nearly all the common hardware I was using (except CPU and PSU) and was still able to duplicate it. I even swapped out my Areca Hardware RAID controller for the built-in one on the motherboard and I got the same results. The only conclusion I could think of is that the secure erase must have done something to the drives to where they are losing data during a shutdown. Just to be sure I took out the SSD's and replaced them with HDD's, no issues at all running on the same hardware. I figured maybe there was an issue during the secure erase so I re-erased the drives again but it did not resolve the issue.

 

I have been in the IT business since 1998 and this is the most bizarre issue I have encountered. I could understand one, maybe two drives, but all six? Has anyone else seen this odd phenomenon? I made sure the drives all have the latest firmware. It looks like I may have to RMA all six drives but if I would appreciate any suggestions anyone might have before I take that step.

 

Thanks,

Randman76

Link to comment
Share on other sites

Did you mean to say "A secure erase should not cause a SSD to lose data during a shutdown"?

 

Please see answers inline

 

Latest BIOS/Drivers/Windows Updates?
I have tried two different motherboards (different BIOS's) which also are accompanied by different drivers and I get the same issue. Doesn't seem to matter with the Windows update. I've duplicated this with all updates installed and installing Windows (without windows updates) and shutting down.

 

Tried different SATA data cables?
hen using my RAID controller card it comes with SAS ->SATA breakout cables that I can only use with the card. When I used the SATA connections natively on the motherboard I was forced to use SATA cables. In both instances I experienced the issue

 

Does Event Viewer list any shutdown errors?
No shutdown errors. The only errors I can see is during a checkdsk. (i.e, orphanded files, free space not allocated, ect...)

 

Also, one thing I did not mention is that in some cases the corruption is so bad I cant even start windows. Sometimes I will get an error stating that my MBR is corrupt and to run windows repair and other times it automatically starts windows repair upon powering on my PC.

 

THanks,

Randman76

Link to comment
Share on other sites

  • Corsair Employees
What you have posted would suggest some other issue but to be sure its not the raid card I would try to create an array with only three drives and see if you still get that issue. Also I have seen when more then three drives used on a raid controller the controller gets to hot and over heats. So this will help to test if it has anything to do with the raid card and if so its an easy fix just add a fan to the Raid card controller if that is what it turns out to be.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...