Jump to content
Corsair Community

M60 stopped working


Ardalista

Recommended Posts

I purchased an M60 mouse on the 5th of June.. it had been working great since then.

 

Today my PC crashed and I rebooted it..

 

After the reboot the mouse lights up and the DPI toggle is registering within the Corsair M60 software... however if you move the mouse nothing is happening.

 

I tried a different USB socket

Tried removing the software and re-installing it

tried different report rates in the Corsair software, lights go out then come back on but nothing :(

rebooted numerous times.

gave up and submitted RMA #4753329

Link to comment
Share on other sites

try and plug in a different mouse while leaving the M60 plugged in also then load the corsair mouse software, select manage performance and change the report rate, thats all I ended up doing and that fixed my problem and I've not had an issue since.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...