Jump to content
Corsair Community

K90 accented capital letters macro


Nehluxhes

Recommended Posts

Hi,

 

Since I don't play MMO I found another use for the macro keys, I want to use them to type accented capital letters (É È À Ç etc...)

Problem is, it doesn't work. I record things like Alt + 183, then when I try to use it in notepad or elsewhere, it types nothing...

 

Macro keys work fine since doing things like Maj + letter is ok...so what is the problem?

Link to comment
Share on other sites

Just tried reinstalling drivers and using another usb ports, no change.

 

Typing capital letters with macro works fine, it's ACCENTED (and thus not with Maj + something) capital letters using alt + number wich don't work (these things here )

 

Now even weirder, if using my alt + 144 (É) macro in notepad doesn't write anything, using it in wordpad brings me the save window as I was using the control + S shortcut, but using it in OpenOffice don't do anything, though it's the same shortcut... :confused:

(all of that NOT in hardware playback mode, otherwise it doesn't do anything)

 

 

Btw, I am using an azerty K90 under a french version of 7, if it is relevant.

Link to comment
Share on other sites

Accented cap letters in HW work for me. Just a question are you using the numpad or the other line of numbers to do this? Using numpad accents work fine but using the other numbers absolutely nothing happens.

 

I've tried about every combo on that page and every one seems to be working ÉÉÉ :P

 

I guess if that isn't the problem it boils down to an 16 bit AZERTY problem or a bad keyboard.

Kinda surprised corsair hasn't stepped in yet.

Link to comment
Share on other sites

I am using numpad numbers too, else it doesn't work even without macros.

 

It would be so great to be able to type these letters with macros instead of having to remember and type a dozen of codes :(

 

I think the keyboard works fine since I am even able to type entire sentences usings macros...but not in HW. Nothing seems to work in HW. Perhaps that's the problem?

Link to comment
Share on other sites

One more question, are you saving the macros to the k90 in the manage profiles page? If that isn't it someone else is going to have to come in.

 

edit: In order for HW mode to work macros must be saved into the k90s onboard memory

Link to comment
Share on other sites

Well, you found the problem, I was not saving them on the onboard memory, thought it already was the case with the MR button...now it works!

I feel a bit stupid now, but well I am not really used with these fancy keyboards with lots of stuff in them :D:

 

A BIG thanks to you! :praise:

 

 

Oh, and a real bug this time which don't really bother me but anyway : my previously recorded sentence is typed in qwerty mode in HW.

Link to comment
Share on other sites

Oh, and a real bug this time which don't really bother me but anyway : my previously recorded sentence is typed in qwerty mode in HW.

I remember that on my system (Win 7 x64, in english) I had something similar: my previous keyboard was azerty (french), when I swapped for a qwerty K90 it was seen as azerty.

 

I think the issue is in windows settings for the keyboard: check them from control panel.

 

MaX.

Link to comment
Share on other sites

Yes I know how to switch between azerty/qwerty mode and I type in azerty right now, but things stored in the k90 memory are typed in qwerty by using macros ONLY in HW mode.

So if I recorded a macro to type 'a', it will type 'q' in HW mode and 'a' if I am not in it (or not using macros at all).

 

Now it really doesn't bother me (for now :p ), I just say it for...the sake of reporting a bug :p

Link to comment
Share on other sites

Yes I know how to switch between azerty/qwerty mode and I type in azerty right now, but things stored in the k90 memory are typed in qwerty by using macros ONLY in HW mode.

So if I recorded a macro to type 'a', it will type 'q' in HW mode and 'a' if I am not in it (or not using macros at all).

 

Now it really doesn't bother me (for now :p ), I just say it for...the sake of reporting a bug :p

 

It was doing the same for me. I had to remove the previously existing locale settings (language and keyboard layout) and put only the relevant one.

 

Can't remember if I have re-recorded the marcos after that, can't hurt.

 

MaX.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...