Jump to content
Corsair Community

Accelerator SSD Cache Drives

Recommended Posts

I am having installation problems with Dataplex v1.1.3.3 on a 60GB Accelerator drive that until now has not yet been resolved. Even though Dataplex (NVELO) (and hopefully Corsair soon) have been very helpful I wanted to post this so that others can see (hopefully) how my problem gets resolved (maybe other users can help me as well which would be great).


My problem is that I keep getting an "Invalid Product Key" error. I sent NVELO a scan of the key from the back of my drive along with my best guess at what the 28 character code was and they confirmed I had got it right. However the software installation keeps throwing it out as invalid.


I have been advised to disable anything that looks like a firewall as the problem may be the application can't send/receive to the licence server.


I have disabled my anti-virus/firewall (Kaspersky), windows firewall has always been disabled, the firewall in my BT Home Hub and I have also disabled Windows Defender.


Despite all this the Product key is still rejected and I am running out of ideas. Hopefully Dataplex/Corsair will come up trumps but if any one else has any suggestions I am all ears!


I will of course post the solution if and when it becomes known.



Link to comment
Share on other sites

This problem has now been solved but the issue was an obscure one and I doubt if many (any?) other people will encounter it.


Having verified the Product Key I was entering was the correct one NVELO requested that I run the following command:


cd to the directory that you downloaded dataplex

cd corsair_dataplex_v1.1.3.3\win7_i386\dataplex\cachefilter

then type

addfilter.exe /verify /productkey xxxx-xxxx-xxxx-xxxx-xxxx-xxxx


(xxxx etc being the real product key of course).


I got the following error:


UpdateServiceRegistry: Unable to open registry key SYSTEM\CurrentControlSet\Services\nvelodiskfltr !!! Status = 0x2 (Entry not found)

License failed to activate. Failure:GENERIC_LICENSE_ERROR0.


I then did some research on the internet and decided to look at the Registry myself by typing REGEDIT in the command line.


I then got an error stating the application could not run due to NTDSAPI.dll being missing.


I then searched for this problem on the internet and found a discussion entry that suggested you run the following command (from an administrator command prompt):


sfc /scannow


This searches for corrupt system files and attempts repair as and when possible.


It must have done the trick as I then returned to the Dataplex Installer and at last the Product Key was accepted!


As I say all pretty obscure but you never know this might help someone one day!


It turns out it had nothing to do with Firewalls after all (they are all still active) but rather due to some corruption with my Windows installation.


My thanks to NVELO for their help. Without that first bit of assistance I would never have been able to resolve the issue.


PS Thanks for the reply Wired.

Link to comment
Share on other sites

GJ of Windsor, THANK YOU for posting such a detailed description of the steps you took in getting your accelerator SSD software to download. I was having the same problem--it kept telling me "invalid product key", so I followed your instructions regarding the CMD inputs. When I input addfilter.exe /verify /productkey xxxx-xxxx-xxxx-xxxx-xxxx-xxxx (without the hyphens), I got another "invalid product key", but when I compared that to what you had posted, I tried again WITH the hyphens between the blocks of four characters. The hyphens made the difference for my system. Then, I had to re-run the Dataplex software to get the actual download.


Note to Corsair: If you want to use a 28-character product key, you need to specify in your instructions to include the hyphens. Most other products, like Windows for example, specify that you should leave out the hyphens, or the installation software automatically inserts them for you. Also, when I tried to contact tech support, the Corsair website directed me to apply for an RMA. That would have been a shame if I had followed those instructions. Thank goodness for GJ's excellent post!

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...