Jump to content
Corsair Community

Any compatibility issues between Asus P8Z68 Delxue and Corsair SSDs?


Recommended Posts

Guy's, are there any known compatibility issues between Asus P8Z68 Deluxe GEN3 motherboard and Corsair SSDs or is it just that corsair SSD's are unreliable?

 

I recently got a Corsair GT 120GB SATA 6Gbps SSD and connected it to my Asus P8Z68 Deluxe GEN3 board via the first Z68 SATA 3 port. The drive kept disappearing randomly (does not even show up in the UEFI BIOS) as soon as I start the windows 7 64bit install. I tried everything and finally switching off SMART ensured that the drive does not disappear. I went ahead and installed Windows 7 64 bit and used it for about 2 hours and poof popped on IO Error. The SSD is no longer getting detected.

 

Coincidentally I had previously tried to install an Corsair Force Series 60GB (SATA2) SSD on this very machine and with that too I had faced similar problems with the SSD becoming unusable. None of the hardware is really new and its working rock solid with HDDs. I don't really see any problem with the board itself, but two Corsair SSD's failing is a bit much for a coincidence.

Link to comment
Share on other sites

I have the ASUS P9X79 Deluxe, so it isn't the same board -- but I have my Force 3 120 GB working fairly well.

 

Not familiar with your board but since you say it is GEN3 it should probably do SATA 3.

 

Your board should have some Intel SATA 3 ports I think. You should plug into Intel SATA port 0 or 1 depending on how you count :)

 

If you don't have Intel ports use the first SATA3 port but don't plug into a Marvell controller.

 

The BIOS should have your SATA set to AHCI. If it was not set to AHCI when you installed Windows you may have to use a script available here to fix the registry.

 

Hopefully you can then see your drive.

 

You need to use the firmware updater tool available here free and check the firmware version in your SSD. Make sure it is 1.3.3 or upgrade it if needed.

 

Also go to ASUS and download and install all the latest motherboard driver upgrades for your MB.

 

Hopefully these steps will fix your problem.

Link to comment
Share on other sites

Guy's, are there any known compatibility issues between Asus P8Z68 Deluxe GEN3 motherboard and Corsair SSDs or is it just that corsair SSD's are unreliable?

 

I recently got a Corsair GT 120GB SATA 6Gbps SSD and connected it to my Asus P8Z68 Deluxe GEN3 board via the first Z68 SATA 3 port. The drive kept disappearing randomly (does not even show up in the UEFI BIOS) as soon as I start the windows 7 64bit install. I tried everything and finally switching off SMART ensured that the drive does not disappear. I went ahead and installed Windows 7 64 bit and used it for about 2 hours and poof popped on IO Error. The SSD is no longer getting detected.

 

Coincidentally I had previously tried to install an Corsair Force Series 60GB (SATA2) SSD on this very machine and with that too I had faced similar problems with the SSD becoming unusable. None of the hardware is really new and its working rock solid with HDDs. I don't really see any problem with the board itself, but two Corsair SSD's failing is a bit much for a coincidence.

 

Its not the corsair ssd's that are unreliable, because my two 240's work exceptionally well. Have not had any problems at all so its probably your system. I have read alot posts and i see most people but not all that are having problems with ssd's are the ones with the newer systems ie. motherboards and such.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...