Jump to content
Corsair Community

Corsair Flash Voyager GT 64 GB problem


Cyclops25

Recommended Posts

Hello!

I recently bought a Corsair Flash Voyager GT 64gb usb 3.0.

The problem is when i put it in my usb 3.0 slot the drive is NOT recognised by windows 7.

BUT it works flawless in any USB 2 i have tried.

 

Here is what happends when i put it in USB 3 slot: starts blinking, after about 10 seconds i hear the "durip" sound when usb things are inserted, then the blue light just blinks endless. Tried to leave it like that overnight, but still flashing when i woke up the day after.

 

I have 2 USB 3 external hardrives that works normal on usb 3 controller.

 

i just copied 59 gb to the drive to test if it was a fake (bought it on ebay) but all data seems fine. no errors. Used USB 2 ports for this.

 

Tried to format it using NTFS, ExFat, and Fat 32 (still using usb 2) to no avail.

Tried the sdformatter on http://www.sdcard.org. still same.

 

What to do?

 

Edit: Just uninstalled the driver for usb 3.0 card, rebooted and installed driver again, now i see that the Corsair install itself as "unknown device". Still the same problem though.

Link to comment
Share on other sites

I had the same problem with Win7 (with Linux - no problem).

Try reboot with inserted flash drive, do not remove until detection not done. Repeat with all USB3-port insert-reboot for correct detection. Only this way was successfull on my VIA VL800 USB3 controller.

Link to comment
Share on other sites

Hello!

Thanks for the replay.

How many restarts did you need? did 10 just now but still no detection.

 

what i did:

Inserted the stick while power was of->started windows->waited for the detection sound->hit start and reboot. <-repeted that 10 times exept for the inserted stick while power of, it was inn for the whole 10 restarts.

 

do i have to completely power off (not restart button)?

Link to comment
Share on other sites

What USB3-controller do you have? I have pcie1x controller on VIA VL800.

For the normal work I need: power-off, reboot, or go to sleep, or hibernate. As I see, flash drive detection lost every time when I re-plug it.

 

So, I do some steps:

1. Download latest drivers

2. Manual change driver from "Unknown device" to "Mass storage device for USB"

3. No unplug flash drive! Then reboot/sleep etc.

 

I think that is electrical power problem or bad drivers...

Link to comment
Share on other sites

Problem fixed!

Just started working when i booted up this morning.

so rebooting seems for fix the problem.

I think its the same as yours. OR a VL801.

This is the one exept 2 small details, i dont have the blue BROWAY sticker under the micro sd slot. and there is no "clamp" for the PCI-E connector.

http://www.ebay.com/itm/3-5-Front-Panel-Internal-PCI-E-To-USB-3-0-4-Port-Hub-Combo-2-0-Card-Reader-A008-/250962642316?pt=LH_DefaultDomain_0&hash=item3a6e8a058c

 

i have the latest firmware and driver, all downloaded from here: http://www.via-labs.com/en/support/downloads.jsp 1.9A is the newest at the moment.

 

Must be a driver issue if you ask me, since it works great on usb 2 and that gives alot less power than 3.0.

Might be firmware too. maybe Corsair should contact Via Labs to see if anything can be done.

if you read this Ramguy-^

 

Edit: any way to identify the controller without looking at the chip? could be usefull for further driver/firmware upgrade.

Link to comment
Share on other sites

any way to identify the controller without looking at the chip? could be usefull for further driver/firmware upgrade.

Try ChipGenius. It almost always finds out which is the controller of a pendrive, and while it's not as good at finding which is controller of the host, it'll for sure give you its VID&PID, at the very least. MS USBVIEW (available from the debbuging tools package [it's portable, just extract it with 7-zip into a convenient folder and run it]) is also an alternative option.

Link to comment
Share on other sites

Well, heuristics are nowadays somewhat ultra-paranoid. I believe it's nothing but a false-positive, too.

However, some paranoia is good, so I've submitted it to VirusTotal, and here are the results:

ChipGenius.rar 15/41

FlashGenius.exe 18/42

MyDiskTest.exe 1/42

ChipGenius_v4_00_0024.exe 2/42

Of those detections, only FlashGenius.exe has some detections which apparently are not heuristic results. In any case, it still looks to me all these detections are false positives.

But, on the bright side, FlashGenius.exe and MyDiskTest.exe are not needed at all. The only files that need to be extracted from the rar archive are ChipGenius_v4_00_0024.exe and Chips.wdb. Those I'm quite sure do contain any malware at all, the pair of detections that VirusTotal reports for ChipGenius_v4_00_0024.exe being blatant examples of hyper-paranoid heuristics.

Thanks for the heads up.

Link to comment
Share on other sites

Update on the issue:

 

Had to remove the Corsair GT to another computer.

When i put it back in the USB 3 on this computer same happends, only "unknown device" detected.

Got frustrated and pulled it in and out a couple of time. did not work. got more frustrated and pulled it in and out and in again fast. NOW it works. got the "would you scan the drive for error" did a quick scan and no errors.

So thats a possible solution i guess.

Link to comment
Share on other sites

  • 2 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...