Jump to content
Corsair Community

H50 becomes very noisy :(


Tweety63

Recommended Posts

Hello !

 

I have the H50 watercooling kit for some time now (December 2010) and for several days now, it becomes very noisy.

 

The sound is like a very noisy and constant hard drive read/write and comes from the pump. It's not some bubbles caught in the circuit sadly.

 

The cooling is good, but the noise is very very irritating. :-(

 

Is there a solution to correct this ?

Link to comment
Share on other sites

Thanks for the quick response but how do I do that ? I see nothing to control the pump speed. It's at 1350rpm presently.

 

And the pump was ok for several months before I got this noise, it's not a fresh install.

Link to comment
Share on other sites

The H-50's are totally different that the current 60,70,80, 100 series coolers. The pumps were manufactured by a different company and did not have the same pump issues. So lowering the pump speed or attempting to would not be advisable in this situation. I wish they would have stayed with the 50 series pumps. They were pretty trouble free. If you browse the forums a little they did not have near the problems . . Sadly i gave mine to a friend. 2 1/2 years and still running strong.

 

My guess is the pump has just failed or finally wore out.

 

Since they are a few years old and discontinued, i believe the only solution would be an RMA if the OP still has time left on it. And even then i believe it would be replaced with one of the newer coolers.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...