Jump to content
Corsair Community

M90 faulty?


SolidCrew

Recommended Posts

Hi,

 

I have the latest beta software installed.

 

When I first installed my mouse there was a little light on the side of the mouse that I think is to show what memory bank it's using.

 

PROBLEM 1:

That light has not lit up in a long time.

I used to have problems with the mouse not working and I had to do the LIFT HEIGHT to get it to work.

 

PROBLEM 2:

Lately I've also noticed that the mouse scroll wheel seems jumpy.

When I use the mouse wheel it will jump up and down web pages rather than moving smoothly.

 

Is there any option to reset the mouse via a firmware flash?

Link to comment
Share on other sites

This is the link to the firmware update thing:

 

http://www2.corsair.com/software/M60_90/M90110211v108.zip

 

Thanks.

 

Do you have any idea how to save to another profile to make the second light actually light up on the mouse.

 

That firmware restore got the light back on but I can't seem to get it to light up anymore no matter what I do.

 

thanks

Link to comment
Share on other sites

Thanks.

 

Do you have any idea how to save to another profile to make the second light actually light up on the mouse.

 

That firmware restore got the light back on but I can't seem to get it to light up anymore no matter what I do.

 

thanks

 

The profile lights depend on whether you're in software playback or hardware playback mode I think. The steps in this thread should fix things.

 

http://forum.corsair.com/v3/showthread.php?t=103683

Link to comment
Share on other sites

Correct. You need to have hardware playback selected, and the profiles saved to your device through the manage profile screen.

 

Yer just followed that guide. All lights lit up when you move through the profiles.

Crashed the mouse. Cursor would not move at all.

LIFT HEIGHT did nothing either.

 

Had to do firmware restore again.

 

I want a mouse I can use. Without hassle. I've had problems with this since I bought it. But I held on because I was under some impression from looking on this forum that Corsair was going to resolve the issues with them. How long have we been on this beta? Well considering the issues, too long if you ask me.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...