Jump to content
Corsair Community

Force 3 120 GB F4 BSODs (Tried Everything!)


Stewge

Recommended Posts

Hi guys,

 

Before anyone jumps to the "another F4 BSOD thread" and throws the usual links at me I'll explain what I've got:

 

System is a HP TM2 convertible tablet but as far as general hardware configuration it's practically a laptop. i5-470um, 8GB DDR3, SATA2 on the mobo and running the latest bios revision with a formerly 7200rpm HDD as the only hard drive.

 

I got the 120GB Force 3 after having "relative" success with another drive in my desktop (desktop has a pre-1123 Force3 120GB which is now stable after firmware update + PCH voltage tweaking). This drive for my laptop was bought last week and is brand new.

 

I installed off a blank slate, new drive in and straight install of Windows 7 Ultimate x64 and it was working fairly stable for a day. I wasn't getting random dropouts but shutdown would fail and booting up would require a few tries. I ran the firmware update tool and discovered the drive was already v1.3.3.

 

Next thing I tried windows update, bad idea. Update failed and windows would either not boot up, or bluescreen shortly after. I need the machine running so I installed LinuxMint in a pinch and strangely enough, completely stable! :confused:

 

Come today, I have time to get Windows again and getting dual-boot going (requires Windows installed first). So I've secure erased the drive (through part magic) and run a clean install of Windows 7 64bit. I'm now getting CONSTANT drive drop outs. The first stage of install tends to go through fine, the second stage always blue-screens with an F4 error within minutes of booting up. Immediately after the BSOD reboot I get a hard drive failure warning. I've tried reburning and installing off multiple dvds to insure it's not the Windows CD.

 

So my question, what options do I have left?

 

It's plugged straight into the laptop so no SATA cable issue. The BIOS is extremely limited (being a HP) so I can't adjust PCH voltage or anything (about the only thing I can do is turn on/off Intel VT-X, which does nothing for SSD stability btw.). I've secure erased and started from scratch and can confirm the latest firmware is on the drive.

 

I'm prepared to do whatever fiddling necessary to get this fixed and running. What really interests me is how Linux has absolutely no problems with the SSD. Boots fast, never drops out after rebooting etc. It seems that only a drop-out in Windows causes the drive to no longer be recognised at a BIOS level on reboot.:idea:

Can anyone (possibly at Corsair) confirm this?

 

It would seem to me that the problem may infact be between the SSD and Windows, not just the SSD itself as most believe.

 

That said, unfortunately, if I can't fix this, the reality is I'm going to have to get a refund and go for a different brand. Similarly I can't recommend the Corsair 120GB to my mates based on "maybe it will work if the stars align" :sigh!:.

 

Currently, I'll be trying a fresh windows install off a USB key (TM2 doesn't have a DVD drive, been using a USB external) as a last resort.

 

Thanks in advance :)

 

UPDATE:

Tried USB install, still fails every time. Installig LinuxMint (Ubuntu derivative)on it now and seems completely happy with that. I'll give it a couple more days to find a solution, but if not the old 500GB drive is going back in and I'll be sending the corsair drive back.

Link to comment
Share on other sites

if linux runs without any problems whatsoever, it's not the hardware itself.

 

The only voodoo tricks I've stumbled upon I can think of are the setting the Power Plan to "high performance", and using the DPM reg hack to disable the disk power management. (The DPM reg hack only works with Intel RST drivers btw).

 

Other than that using the standard MS AHCI drivers could work as well (also here, there is a reg hack to "force" the drive to appear as internal, instructing the driver not to "do certain things to the drive", which could make it more stable)

 

I know at least the Power Plan change itsn't really viable in a notebook, but if you have the time to put in the effort and don't mind trying out some stuff, give my recommendations a shot.

Link to comment
Share on other sites

Plug the SSD into a desktop computer and install Windows. Then install it in to the HP. make sure you install the drivers for the tablet.

 

Might have to try this. Got plenty of desktops in bits I can use as a basis.

Since I can't actually get it installed on the laptop unfortunately I haven't been able to actually get to any power settings.

 

I'll see how it goes.

Link to comment
Share on other sites

So, used a spare box to install windows and do all of the SSD tweaking. Couldn't install Intel RST until it was back in the laptop as the donor PC was an AMD board.

 

Seems pretty stable and been through a couple of reboots with updates and such. Still no idea why it was acting so rotten with a direct install :confused:

 

This is probably still something that should be tested further as I find it interesting that throughout all the problems Linux was completely fine. Maybe if Corsair had some "confirmed" dud drives if they could test on a linux platform and swap between.

 

Definitely going to create an acronis image once I've got going, that way I can "restore" to a clean image rather than reinstall and have to go through all this again.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...