Jump to content
Corsair Community

Corsair vengeance 1500 not working after driver/software install


hansy

Recommended Posts

Hello! My corsair headset randomly stoped working a few day's ago. It weren't in the playback device's-menu, so i checked the device manager and there was the headset with a yellow icon right next to it. I tried to uninstall and install the driver's with no luck. Everytime i connected the USB, Windows couldn't install the (basic?) drivers.

 

Today i uninstalled the drivers and runed Ccleaner, restarted and pluged in the headset. I now found it at a different place in the device manager. I right-clicked it and choosed to update driver software and find the drivers my self for ''USB audio device''. It now finally worked and the yellow sign was gone.

 

Then to another problem. The sound was so loud (compared to volume ''0-100''), thin and crispy that i just had to install the driver's. Under the installation the speaker icon on the lower-right turned red and the headset didn't work anymore. Even after the restart.

I checked the device manager again and the headset had yet again gotten that yellow ''warning'' sign/icon.

 

I then right-clicked it and did the same thing as earlier and it worked, but again way to loud and not with the driver's. Then i tried ''Corsair USB headset'' and this comes up (I'm translating from norwegian): '' Windows could not recognize the digital signature that is required for this unit. An recently hardware or softwarechange may have installed an file that is invalid signed, or that is broken, or there may be malicious software from an unknown source- (Code 52)''.

 

Windows 7 64bit

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...