Jump to content
Corsair Community

Dead M60...


Bjones71087

Recommended Posts

I have had my m60 now for about two weeks. It worked fine for a little while, and now only the buttons work....no cursor movement. I have tried everything that I can think of, and I followed directions from a few other posts (re-flashed the firmware, reinstall software, different USB ports, different computers) and still nothing.

 

The computer still sees the mouse, and I have even tried what some other have said and changed lift height around a few times. Still nothing.

 

I put in a tech support request, waited 24 hours, and got no response, I forgot that case number so I put in an RMA request and I have that case number saved.

 

I have never had problems with a mouse before... especially a new one... I normally want something new way before it wears out. I see that many others have had similar problems... so, is this an issue that has been corrected in current production models?

 

Thanks,

 

Brandon

Link to comment
Share on other sites

Received message and responded. As I mentioned in my post, I have already tried re-flashing the firmware. What is the best way to go about getting this taken care of? Waiting 2 days between question and answer is not good customer service, is there an instantaneous chat for problems like this? Basically, I have a sixty dollar paper weight. The store I purchased the mouse from is 90 miles away, I don't feel like driving that far to return it.

 

I don't beleive this is an isolated problem with just my mouse, seems like the failure rate is ridiculously high.

 

Thanks,

 

Brandon

Link to comment
Share on other sites

I really can't believe how terrible the RMA process is with this company... I have always bought corsair products because I have felt like they are a higher quality product... I have never had to use the RMA process here, and to be honest, if I had ever used it, I would have never bought another Corsair product again... I'm still in my return window with the store I bought the mouse from... and if i have to wait several days between communication, that may be my best bet, unless we can get this sped up. I would like to make sure my replacement mouse works before I can no longer get my money back on the thing... 60 dollars isn't a lot for a mouse... but it is a lot of money to just throw away on broken stuff.

 

-Brandon

Link to comment
Share on other sites

  • Corsair Employees
I'm sorry for the delay. I'm showing that your first forum post was answered within 24hrs. The next day you were advised an RMA and to update your shipping information. Until we have that shipping information we do not have a way to process the RMA for you. I reviewed your case and your RMA was approved.
Link to comment
Share on other sites

It's not the forum response that I was upset about... It's the fact that it took 4 days AND me having to get on the forum to even get a response. I only got on the forum because I had not heard back from the "tech support" link.

 

I am not trying to be rude... I just feel that the process could be made more efficient.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...