Jump to content
Corsair Community

M60 not working from start...


StuntJester1

Recommended Posts

Ok came in the mail today and already filled out the support email. But want to make this thing work.

 

Plug-in and windows installed drivers auto, and nothing did not move the arrow or buttons work. So plugged in old mouse and when and downloaded software from site. Still not working, you can turn the LED on and off from the software so it see the mouse. I when into device manger and it look like Window 7 is showing it as keyboard not a mouse. Removed all drivers and tried again. Same thing. Reading the forum I saw maybe a firmware issue. Downloaded the "M60 firmware update 110711 v107" and ran still nothing. I don't understand why a big company like Corsair has this problem. Friend bought same mouse running same Windows and works no problem. Please help! This was a gift and really don't want to send it back but I will.

 

Software: 1.00.00.02

USB Mouse:

VID: 0x1B1C

PID: 0x1B30

Manufacturer: Corsair

Product: Corsair M60 Mouse

Firmware: 1.07

Windows: Windows 7 Ultimate 64 bit

Link to comment
Share on other sites

  • Corsair Employees

Sorry to hear you are having issues with your M90.

 

It looks like you are running the latest software 2.12 according to the information you had provided.

 

Go ahead and re flash the firmware again:

http://www2.corsair.com/software/M60_90/M90110211v108.zip

 

Also make sure your bios and USB drivers for the motherboard are updated. Make sure you plug the mouse into a USB 2.0 port, or try other ports on your computer.

 

Can you confirm this issue occurs when the device is plugged into another PC?

Link to comment
Share on other sites

I just bought the mouse today and the lights come on but windows doesn't recognise it, ive tried multiple USB ports and machines and they all have the same problem.

I tried to install the software but the install says it cant find the mouse.

 

This mouse was to replace another mouse that ive had for five or so years.

Link to comment
Share on other sites

  • Corsair Employees

Please do the following steps:

 

Control Panel > Power Options > Change Plan Settings > Change Advanced Power Settings > USB Settings > USB selective suspend setting > Disabled

 

Then run the firmware update again.

 

If the issue still remains, we will need to RMA the device.

Link to comment
Share on other sites

  • 2 weeks later...

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...