Jump to content
Corsair Community

Force GT 120 1.3.3 fails


Recommended Posts

I've received the SSD some days ago; yesterday I've installed Windows 7 Professional x64, no issues. I've installed the SP1. All good. I've shutted it down because I had not time to continue setting up the pc.


Today I've started up the pc: Windows Start Failure.


I've disconnected all the others Hard Drives and USB peripherals (except mouse and keyboard), same issue.


I've run the Windows Memory Diagnostics Tool: No problems detected.



I've tried to re-install Windows 7, all went good until the first reboot:


"A disk read error occurred

Press Ctrl+Alt+Del to restart"



There is no way to go ahead.

I've tried to set up my old SSD (Intel X-25V 40GB) as first boot disk and the Corsair as secondary: Windows booted but after few minutes the system freezed.

I've restarted, but the Windows logo remained stuck.


I've removed the Corsair SSD: the system ran stable.


I wasted 4 hours trying to figure out how to solve the problem also reading through the forum without success. I hope I will not have to ship back the ssd to the customer.




Same Windows Start Failure occours with an installation of Windows 8 Consumer Preview:

"The operating system couldn't be loaded because a critical system driver is missing or contains errors"


If I press Enter to try again, the same error occours but with another system file.




That's a real strange thing. I've mounted the SSD on a VAIO with Intel GS45 Chipset... and it performs good. I've installed correctly Windows 8 CP, it's running well...

So the problem is the mainboard, the Crosshair IV with its AMD chipset!?

Link to comment
Share on other sites

-Reset the BIOS to defaults by shorting the pins or removing the battery.

-Tried updating the BIOS?

-Tried various SATA data cables and motherboard ports?


The Motherboard BIOS is already updated (there is only one more beta version, but i don't want to install it as it is a Beta).

I'll try to use different cables and ports... the strange thing is that the notebook is running well with it, except for the sequential writing speeds (150/160MB/s)

Link to comment
Share on other sites

I have removed all SATA peripherals, and connected ONLY the SSD on the SATA #1. It is running well also with an old SATA I cable I've got.


If i put more devices on SATA ports it starts "erroring"


It's a "forever alone" SSD...

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...