Jump to content
Corsair Community

Vengeance K90 macros in game not working


Shetep

Recommended Posts

Hello, I recently purchased a Vengeance K90 and the look and feel is great, but it's not doing what I expect it to be doing, and I'm here to figure out what I'm doing wrong. I feel like this is the most basic of possible questions to ask, but nothing I do is working and I couldn't find help from the search function.

 

Say I want to open up Guild Wars, and my logout button is bound by default to F12. I want to assign G12 to press F12 once to get the logout window to pop up, but no matter what I do, I cannot bind G12 to F12 and get it to successfully work in game.

 

Updated firmware to 1.07 and most recent software. Even uninstalled everything and re-installed just to make sure nothing was corrupt.

 

Tests I tried:

- Making a custom profile and assigning GW.exe to profile, then using GW.exe to open game. First I used the software outside of the game to manually bind G12 to F12, and then opened the game using GW.exe. G12, when pressed, would not do what F12 normally does in game. Afterward I tried using the quick macro (MR>G12>F12>MR) while in game, but to no avail. Still no luck getting a G key to provide the function of an F key in game (or any key for that matter).

 

- Working off default profile. Opened up google and bound G12 to F5 using the quick macro bind (MR>G12>F5>MR), hit G12 and it refreshed the page as it should. Then alt-tabbed into Guild Wars and hit G12, didn't react to what F5 normally does in game.

 

- Made a profile for Counter-Strike : Source. Everything worked flawlessly. Bound G1 to F3 and hit G1 to see that the game responded as if I had hit F3 in the first place. This is what I want, but in games that I actually play.

 

I tried uninstalling the firmware and software and re-installing them. I also tried to end K90Hid.exe and run it as administrator but that wouldn't help anything in game either. All I want is to make G12 bound to F12 and G18 bound to F10 in ANY game that I play. I only used Guild Wars in my example but I also tried all of this in Dragon Nest and neither game would allow me to bind any G-keys to any key on my keyboard for use in game. Any help is appreciated.

 

Edit: Whenever I tried a new bind, I would always go to 'Manage Profiles' and click 'Save to K90' but still got the results posted above.

Link to comment
Share on other sites

I made an account just to reply to your post.

 

I literally have this EXACT same problem. I purchased the Corsair Vengeance K90 and am also unable to use my binded keys within Guild Wars. I've set the macro up according to the FAQ on Corsair's website (MR>key>MR) and it won't recognize that I'm pressing it. If I assigned a macro key to the letter "E" and pressed it outside of Guild wars (like in an address bar in a browser), it would work just fine. I've tried checking and unchecking the hardware support (whatever that checkbox in the bottom left of the software is) and this also didn't fix it. I've updated my firmware to the latest by downloading the firmware update from Corsair's website. I would love to be able to use the macro features in this game, as this is exactly why I bought the keyboard. Sadly, it's not working for me either.

Link to comment
Share on other sites

Hey Shetep,

 

I think I found a resolution. I was able to map "E" to my G1 key and it worked.

 

This is what I did:

 

Click the MR (Macro Record) button.

Click the G key on the screen you want to assign.

Press the buttons on your keyboard that you want to macro (I've only tested with one key so far)

Click the MR (Macro Record) button again.

Click the manage profiles category at the top of the application.

I named my profile name "Guild Wars" and right clicked the application field and pointed it to Gw.exe (located in your Guild Wars folder).

Make sure Hardware Playback is checked on the bottom left of the box.

Click "Save to K90" button.

Wait til' 100% on the upload to onboard memory.

Reboot GW if you have it open and try it out.

 

If you're confused by my instructions, you can whisper me in Guild Wars.

 

IGN: Tune Jmc

Link to comment
Share on other sites

You, sir or madam, are amazing. That worked perfectly for me in Guild Wars, and I even tried it in other MMOs that I play such as Dragon Nest. Worked flawlessly in both. You have saved me a lot of time and effort, and I thank you for your help.

 

For anyone experiencing a similar problem, I recommend you follow this procedure. Thanks again.

Link to comment
Share on other sites

  • Corsair Employees
Correct when you test a macro in say note pad, note pad has to be run from software to be able to read the macro, lets so you try the same macro in a game, it needs to have hardware mode selected and loaded into the device.
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...