Jump to content
Corsair Community

nForce Chipsets and SSD SATA II Compatability Issues


Recommended Posts

Let me start by saying I apologize if I breach any of the listing competitor rules. In this I will be listing partner vendors if anything. Also I will caveat that this may be long since the script here is derived from a conversation I just had with nVidia live-chat support and I would just like to elevate this on all sides so there is no finger-pointing or handing off by any "manufacturer" involved. I spent 6 years in the US Air Force doing network infrastructure and circuit level component troubleshooting and when working with the distant end I absolutely hated the "It's not my problem," defense because it never solves anything. And so, I digress.

 

I recently purchased a Corsair Force GT 180 GB SSD from Newegg and to get right to the point am getting SATA I 1.5Gb/s speeds on a SATA II 3.0Gb/s Motherboard port.

 

Since the controller shows that the other 5 drives I own show up as SATA II 3.0Gb/s I suspect driver issues on the side of the nForce controller ASUS Mobo or firmware issues on the side of the SSD Manufacturer.

 

Now because of the research I have done I have found that others are having this same problem with 5-6 and 7 chipsets (but not necessarily with Corsair SSDs) and many of the forums I have found get people saying something like the manufacturer won't reply to me on either end or they referred me to the chipset mfg or vice versa.

 

Essentially, it boils down to a chipset and drive speed negotiation issue both the drive mfg and nvidia or the motherboard mfg and nvidia are playing a mere finger pointing game which realistically solves nothing and leaves a customer frustrated that they bought a SATA III 6Gb/s drive for near 300 American Dollars knowing they should get SATA II speeds for now until they upgrade other system components only to find they have to settle for SATA I without any real solid answer other than your stuff is old.

 

I have upgraded and tried about every driver combo I could find from nforce chipset SATA controller drivers to the ASUS JMB36X Controller the Nvidia Nforce controller drivers and Microsofts SATA controller drivers.

 

My motherboard is the ASUS M2N-SLI Deluxe

Also the onboard nvidia product is the nForce570 SLI

 

(This is the response after the nvidia associate looks into the problem.) Okay, from the specs of the motherboard & the graphics chipset both supports the minimum speed SSD you are trying to use on the 3.0Gb/s Motherboard port. However, as you mentioned that you use both the drivers from the motherboard manufacturer as well as our drivers, this is not the normal behavior of the chipset/board..

(They proceed to ask me to list the drivers I have tried.)

 

The nForce Serial ATA Controllers I have tried are: v10.6.0.19 dated 8/6/2010, v11.1.0.33 dated 8/4/2009 and v11.1.0.43 dated 4/9/2010 which is what installs from the nForce MCP Chipset v15.58 most recent download from your website. In this regard I have also tried the "Standard Dual Channel PCI IDE Controller" which is the Microsoft Driver for it.

 

Now, for the Storage controller I have tried the the JMicron JMB36x Controllers v1.17.58.2 dated 8/10/2010 and v1.17.62.0 dated 11/25/2010 as well as the Microsoft Standard AHCI 1.0 Serial ATA Controller.

 

(Again, their response.)

Thank you for all the details, as you have tried all the basic troubleshooting steps I will go ahead & escalate this case to the level 2 support to help you explain/fix or for further troubleshooting..

(I proceed to thank them and say I will bring this up to Corsair and ASUS as well in hopes of solving this from all sides.)

 

Now to clarify a few things for this forum. I am using the latest Firmware for the drive 1.3.3 and I did not have to flash it, it came up to date. I have not tried to flash my bios to a newer version as I had to flash it multiple times a few years to find the correct version that would work for the Phenom Quad core I had upgraded to which was in March 2010. Only two beta BIOS have come out since then which I will look into a little deeper. The benchmarks I have run using ATTO have all been around 110MB/s write and 140MB/s read. Lastly, I installed using the AHCI selection in my current BIOS.

 

Please Please Help.... Corsair or anyone with a similar experience. I realize this is older stuff but as the nVidia rep said. They are both capable of SATA 3.0Gb/s and "this is not normal behavior."

 

In all honesty, because I have found many others using drive brands other than Corsair but most having nForce MCPs on their mobo, my instinct as a former network tech says that it's probably not a problem with the drive (which it still could be) but I want it known to all the manufacturers involved in my situation for the best possible outcome for myself and possibly many others which is why I went into such great detail.

 

Thanks,

-Kyle

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...