Jump to content
Corsair Community

dead F80


Recommended Posts

INTERESTING. I just joined here to post a reply because the SAME THING JUST HAPPENED TO ME!!

 

I had this drive about 5 months now, Corsair Force F80, and my wife was on her computer a few minutes ago and most of today actually, then she came back after a break and Windows had hung (on the lock screen). We had to powercycle the computer. When it rebooted, she got errors in the BIOS saying boot disk not found and in the BIOS settings, it shows no drive. I tried swapping power and SATA cables from the other drive (backup drive, non-SSD) and it showed up in the other spot but the main Corsair SSD was still not found. I rebooted between each attempt, even tried different cables and motherboard SATA port combinations. I even put the SSD drive in my own computer (which has multiple drives which includes an F120 Corsair might I add, and I've had that 2+ years now w/out problems). But still this newer F80 seems totally dead. Hosed. I have to RMA it now I guess, at least there's a 3-yr warranty!

 

:(:

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...