Jump to content
Corsair Community

Problem with my Rampage 4 extreme and an AX1200 psu


mcj66106

Recommended Posts

  • Corsair Employees
I would suggest you submit for an RMA on the PSU and contact the MB maker to look at the MB. Once you have the case number please post it so I can request some testing on the PSU you send in.
Link to comment
Share on other sites

I need to rma my old HX1000 first. Then after it gets back I can go ahead and send in the AX1200. I have rma numbers for both of them as well as the cables that where used on the AX1200. The motherboard is in the process of rma as well and should be back in my possession by the end of the week. its going to take about a week before i can get the HX1000 shipped and probably a week after i get the HX1000 back I can send in the AX1200. I took down the pictures of the damage but can post them back in this thread.

I really don't think it was the psu or the cables and neither do the 3 electronics repair shops I have had look at it.

 

http://i1215.photobucket.com/albums/cc507/mcj66102/2012-02-29_17-11-11_386.jpg

 

http://i1215.photobucket.com/albums/cc507/mcj66102/2012-02-29_17-10-08_947.jpg

 

http://i1215.photobucket.com/albums/cc507/mcj66102/2012-02-29_15-21-14_751.jpg

 

http://i1215.photobucket.com/albums/cc507/mcj66102/2012-03-01_16-58-25_59.jpg

Link to comment
Share on other sites

  • Corsair Employees
I would agree from the damage it appears there was a short somewhere on the MB that caused the current to BURN the MB. But to be safe lets have the PSU tested. Please use the link on the left and request the RMA then let me know the case number so I can request the testing we have mentioned in this thread.
Link to comment
Share on other sites

  • Corsair Employees
Our customer service has left for the day; sorry I was not available earlier today to take care of this but they should contact you tomorrow morning after about 9:00 AM Pacific Time. I have asked them to have the unit shipped to my attention so it can be tested to be sure it is not the PSU problem...
Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...