Jump to content
Corsair Community

Vengeance M60/65/90/95 and K90 Firmware Issues:


Recommended Posts

This doesn't work in Windows 10? (For the M60 mouse)

When i open the devices and printers list (actually "connected devices", translated from Dutch), i see the KDB Bootloader, but right-clicking doesn't do anything. There is only a regular button to remove the device?


EDIT: Wait a sec, i just discovered yet another list of devices, this W10 is frustrating.


It went wrong at step 3.

(names are translated from Dutch settings)

I opened Settings and then Devices.

Then i clicked Connected Devices, which shows The KDB Bootloader, but you can't do anything with it. But...

Instead, at the bottom of that page, click "Devices and Printers", this will get you the same list, but it looks different and you CAN change settings.

Continue with step 3 from there.

Firmware is finally updated now.


Next step is the driver...

Installed it, i am finally able to assign actions to the mouse buttons.

Edited by BounceMeister
Found the solution
Link to comment
Share on other sites

  • 6 months later...
  • Replies 129
  • Created
  • Last Reply

Top Posters In This Topic

hi, i just signed up to say thanks for this, i was about ready to give up (only had my k90 less than a day). What you typed didn't quite work for me (i tried all the steps 3 times on different usb ports), but i found a quicker solution that did. What i ended up doing was steps 4-13. At this point the only thing different was the "corsair gaming device" rename on the kbd boot loader properties. Then i ran the firmware updater without uninstalling anything else. It completed and my glorious blue backlights came back on.


Previously when i first plugged in the keyboard i had the macro software and everything was running absolutely fine until i noticed an irritating problem where my backspace key wouldn't work every press. This caused me to try the firmware update. It did complete and told me everything was fine, except the lights went out and the media keys stopped working etc. I only got the "update mode whatever failed" message with subsequent tries. I think the update screwed up the first time and after that it wasn't able to try again because the device had been renamed.


But yeah. My backspace is working nicely and all i need to do now is redo all my macros. It's a good thing i wrote them all down. Thanks :d:


you beautiful human. I love you, if i could kiss you right now i would.

Link to comment
Share on other sites

  • 2 years later...
  • 2 weeks later...


K90 owner here.

Keyboard works pretty well but the Gkeys (macro) does not work. I can make macro but it's just not work anywhere.


I suspect a firmware problem, because the hardware playback cant be checked in the program, it's say me firmware problem.


But.. impossible to update the firmware with an old one because doesn't work on W10, iCUE not working with k90.


Stuck forever, thank you Corsair..

Link to comment
Share on other sites

  • 1 month later...

  • Create New...