Jump to content
Corsair Community

Vengeance M60/65/90/95 and K90 Firmware Issues:


Recommended Posts

I just did that and it isnt working. My volume wheel works fine and so does my media keys except the mute button. I sometimes have to press it multiple times for it to mute and unmute. Oh and the rewind button is having the same problem too. Its weird and also, how can an LED die out within the first few hours of use yet all the others are working, honestly for $200 NZD this keyboard aint worth it.
Link to comment
Share on other sites

  • Replies 129
  • Created
  • Last Reply

Top Posters In This Topic

All hail LordLobo and Sleeve, Kings of Troubleshooting!


I had this problem with my K90 after updating the firmware the first time.


I followed LordLobo's steps 1-13, then tried running the firmware updater.


...but my lights didn't glow!


So I switched the keyboard's usb cables to another pair of slots and then my lovely lights were back!


So this certainly works, and I am very thankful you guys have the tech skills I don't.

Link to comment
Share on other sites

  • 2 weeks later...
God can not be that I almost have to graduating senior technician in computer science to achieve that my M60 stops working as one of 5 dollars to what they actually buy, the corsair should solve this and fast, thanks to those who took the trouble to help us here, I hope follow well than now onwards my M60.
Link to comment
Share on other sites

same thing with step 12, i have no idea where to go form here i might just go for a RMA but i got it off of amazon as in the uk. im using windows 7 64 bit, only two led's light up on my mouse, the top and bottom profiels, only the buttons 1-3 work and it is not reconised in the setup stage. can any one help haha Edited by Nyle_Mullin
Link to comment
Share on other sites

  • 2 weeks later...

Just created an account for this.


Finally managed to fix this disaster for myself. Long story short; a K90 keyboard update stopped the keyboard working in the BIOS, and I only discover then when I can't boot into Windows... thanks to a faulty Corsair Vengeance RAM module. Installing an alternate firmware on another PC just to use the keyboard again left it in this gimped state for months. All in all, two seperate corsair f**kups led to another corsair f**kup. I also have fond memories of a certain Force 3 120GB SSD drive that liked to drop out for no good reason, eventually leading to corrupting my large RAID. What can I say, except that my confidence in this brand is at an all time high.




My answer, on Windows 8 x64, was a combination of the above solutions -


I began by installing the most recent drivers ( / fw 1.19) onto a seperate Windows 8 x64 machine.


2) MOST IMPORTANT STEP Go to Start->Control Panel->Power Options->Change Plan Settings->Change Advanced Power Settings->USB Settings->USB selective suspend setting->Disabled

3) Plug your K90 into a DIRECT USB 2.0 PORT on your machine.

4) Go to Start->Devices and Printers.

5) Right-click on KBD BOOT LOADER and select 'Properties'

6) Click on the Hardware tab. You should see 'HID Keyboard Device' and another item (I forgot what it says, but it shouldn't say 'Corsair Gaming Keyboard'). Select the other item, then click 'Properties'

7) Click on the 'Change Settings' button on the first page of the Properties dialog

8) Click on 'Update Driver'

9) Select 'Browse my computer for driver software'

10) Select 'Let me pick from a list of device drivers on my computer'

11) Click 'Have Disk' It might look for your a: drive first (good old windows)

12) In the box 'copy manufacturer's files from put 'C:\Program Files (x86)\corsair\K90 firmware update\Driver\X64'


Got the "not a compatible software driver" error crap (see screenshot in an above post) at step 12, stunting progress.


Click dpinst.exe instead and see if that solves it.


Proceeded to run dpinst.exe and installed the keyboard as "HID Keyboard Device" instead (one of the two choices you get before you manually choose the corsair driver in the first place.)


13) You should be able to select the Corsair driver somehow. When your done Your 'KBD BOOT LOADER' properties should have 'Corsair Gaming Keyboard' and 'HID Keyboard Device'

14) Select the HID Keyboard Device

15) Click 'Change Settings'

16) Click the Driver Tab

17) Click 'Uninstall'.


Did the above, and attempted to run the firmware update again. For the first time in what may be five months, it actually worked. Unplugged, different USB port and voila - I have full functionality again.


Adios, until the next disaster

Edited by haxatron
Link to comment
Share on other sites

Hello Friends,


playing LOTRO i use Corsair M90. Its an excellent Mouse and worked splendid...

... until i updated the Firmware (cursing myself for updating something that worked fine)


Since two days, mouse will either not be recognized- or - if i manage to get it recognize the programmable keys do not work any longer, neither do dpi-settings.


No Geek here- so I simply follow screen instructions.

These Error-messages i get (try to translate, have swedish settings):


1) if unrecognized: Unknown USB device.

- I usually switch between the 3 usb-ports and eventually windows searches online after driver.


2) Having a driver then I install the FW-update again- gettting this error msg when running:

'SET FIRMWARE UPDATE MODE FAILED!' and on retry: GET FLASH MEMORY INFORMATION FAILED!' (again - i am not a geek - but i think here lies the clue).


-then i de- and reinstall everything from Corsair (multiple times) and after 10-15 times i get the FW ok. and install the setup.

When programming the mousekeys- everything looks fine in the Launcher- but when i try to save it to profile, it does not exceed 30% - and it does not work when testing.


Again- it worked so fine before- and i spent now 2 days trying to fix this mess. I am really frustrated and need some help.


I shall also try to do with my mouse what the thread-opener did with his keyboard, and hope that might help. (I also have the keyboard, though on my PC. And it works fine so i will not risk a FW-update there).


Here my specs:

Mouse: Corsair Vengeance M90

Computer: Notebook (Asus Zenbook) UX32VD SKU

Processor: Intel Core i7-35178 cpu 1.90-2.40 ghz

mem: 4.00 (3.89 avail)

Graphics: Nvidea GF GT620M

Drive: Hitachi HTS547e3805050a

OS: Windows 7 HP, ACPI x64 based PC

USB Flash Drive (and size): I don't really know what that is, but i have 3 usb ports 2.0

Motherboard: It came with the notebook, and i dont know where to find that info.


Thanks for all help guys, i would really appreciate it. /januk



.......................................... E D I T ............................................................................


Have now tried to fix my Mouse according both ways from LordLobo and from MikeWW, how they fixed their Keyboards (POST ID # = 565066 and

POST ID # = 604177 ) Not working.


LordLobos List i could follow to step 23/24. When i though un- and replugged the mouse to another USB-port, the setup did not recognize the Mouse and did not install. I tried again with replugging the mouse to the same port- same result. I then even made a system recovery to one week earlier, and tried again- by simply leaving the Mouse where it was, not working.


MikeWW steps were better to follow. I made another system recovery - to have clean start and no messed up USB-Ports. After reinstalling the Drivers both- FW-Update and Setup installed with no problem and also recognized the Mouse again. But i am where I started out at: The Mouse has to high DPI, which can not be scaled anymore. Even the Launcher recognizes the Mouse when connected- and let me programme it- The keys do not work when i test it (photo). The profile can not be saved anymore- since the saving percentage do not exceed 30%. And only 2 small lights are working at the left side of the Mouse (photo) The only advantage of this method is, i can use the mouse basic functions again.


What really is a pitty- for both Keyboard and Mouse (prior update) were grand to play with. Having spend now so many hours on that issue, I don't know what to do anymore. Please anyone from Corsair contact and advice me how to proceed. Thank you. /januk




Edited by januk
Link to comment
Share on other sites

Can someone help me with the m90 ? I do all those steps (although i cant see which file is the same to KBD BOOT LOADER) and when i re-install the FW update , it still says that there is no flash memory..can i install the 2.12 beta setup version without having any problems?
Link to comment
Share on other sites

Have you tried reinstalling the drivers?

Latest chipset drivers?


Uninstall the Corsair software and see if the firmware updater works. After the uninstall, check if there are any M90 related processes running Task Manager and close then before trying the reflash.


Take a screenshot or post the text on the information screen by clicking the i icon at the top right hand corner.

Link to comment
Share on other sites

I can install the drivers both beta and version 1.0..but i cant update the firmware..my question is: What if i install the drivers without the firmware update?Will i have a problem?

I also tried re-installing the drivers..did it a 7-10 times..but still i cant do the firmware update..

Link to comment
Share on other sites

Ok. I'm not quite as technical as you, but I think we have related problems. Today my beloved (new) K90 stopped functioning as beautifully as it has been. My backspace is finicky and if I want to type a word with two sequential letters that are the same like feel, I have to type another letter and go back or spam the letter for a while. I CAN'T ENDURE IT!! OMG!! My backlighting is fine. I don't have any macros programmed yet.


Reading your clever solution it looks like I start about halfway down your list with a firmware update? I really don't want to hose my new computer up, so if you can confirm that this is the right path that would be spectacular. Also, where do I get said firmware update?


I am on Win7 64-bit. (A black pearl spec)

Link to comment
Share on other sites

Oh. It was posted in the thread as the one to use to fix the problem. The firmware that was posted is the same one I have on my system. I know because I still have the original zip file. So, I'm guessing that a new driver was applied that is all farged up. The secret seems to be in applying a newer better corrected driver. Any idea where I get one? Do I need a corsair version or do I go to the K90 mfr to get one?
Link to comment
Share on other sites

Ok. That was much ado about nothing. I feel a little embarrassed I even bothered you. :o: I uninstalled the keyboard, uninstalled the firmware, restarted in between each. Then I reinstalled the firmware and VOILA it works. Easy peasy. Maybe not for everyone, but I'm gaming again so I'm happy.
Link to comment
Share on other sites

I got my new M60 today, and I have to say this whole issue is a joke. I was between this and a Razer deathadder and I'm regretting my decision horribly.


The steps in the OP don't work for me. When I try to manually install the driver, Windows 8 won't show me all the files in that folder. Mouse works as a simple scroll mouse and nothing more. Can't reinstall FW because it says memory failed. I really don't know what to do now.

Link to comment
Share on other sites

My first flash attempt (ver. 1.19) finished successfully according to the firmware update software, but my keyboard had the "symptoms" (e.g., backlight off, showing as KBD BOOT LOADER).


I followed the OP's procedure, but at step 21 when I tried to reflash firmware 1.19, I received a "Get flash memory information failed!" error.


I went ahead and unplugged the K90 from it's current port and plugged it into another one (step 23) and tried to re-flash firmware 1.19. This time it worked and the keyboard lit up (back to normal).


I also might have performed step 24 (run the driver setup) before re-flash (don't think I did, but not 100% sure).

Link to comment
Share on other sites

This worked for me. After a couple of frustrated tries, I realized that I have an extra USB 3.0 port in addition to the one I already knew about.


I would still like to make a few things clear:


- Issues like this should not be buried in blog posts and readme files. Issues like this should make you seriously question whether or not you even want to release an update.


- Had I not been inclined or able to come look for a thread like this, I would have simply returned my mouse and keyboard-- to the retailer-- and you never would have heard from me ever again. Trust me when I say that is almost what happened.


- I view this as out-of-the-box failure. I now have no confidence in this product.


- To make matters worse, I see elsewhere on the forum that sticky keystrokes may become an issue down the line as well. (In fact, I think I may have experienced this once already.)


All in all, I don't understand why Corsair isn't much much more concerned about these issues, and to be perfectly frank, I don't know why getting them resolved feels like I'm dealing with a startup company. I don't understand why hardware development is being conducted like it's agile software development.


Know that while I like this keyboard when it works-- in fact, I like it a lot-- I am still very up in the air about whether or not I'm going to return it.


This keyboard retails for $120. Corsair is a household name. You guys seriously need to take a step back and figure out a new approach here.

Link to comment
Share on other sites

  • Create New...