Jump to content
Corsair Community

2x HX 650 Dead, Getting the third now.


Malvado

Recommended Posts

So I've had some issues now with the HX 650 series, the first one silently stopped working overnight about 5 months ago (It had given some instability issues such as games crashing and system hangs before it died) then the next Psu died again overnight.

 

Both of these Psu's where impossible to cold start with paper clips / wire and fans connected to them as of Corsair (or web) suggestions. Replacing them with a new psu powered up the system (Using a 500W spare that probably can only give around 400 to 500w max).

 

All my computer components are connected to the same Electrical grid and have an overcurrent protection, so if it was due to problems coming from that part I guess something else like my Monitor or speakers should also have blown up.

 

I'm just wondering if I'm really unlucky here or if this is something the HX 650 series is plagued with? I'm hoping I can rely on the new 650 coming inn but honestly if that one goes boom as well I should probably consider something more reliable?

 

Is there any official failure rates for the HX , AX and other series of Psu's?

The overall build Quality of the AX series should be higher than the HX series?

Link to comment
Share on other sites

  • Corsair Employees
The build quality is the same for HX TX and AX series PSU's however we may user higher capacity Caps in our AX series PSU's. And the return rate on Hx is less that .015% so the fact you have three that have had an issue might suggest some other issue. What was your previous RMA # and I will ask our customer service to contact you. And please list your complete system configuration. If its not what is in your profile.
Link to comment
Share on other sites

so the fact you have three that have had an issue might suggest some other issue. And please list your complete system configuration. If its not what is in your profile.

 

It's possible you overlooked this, but it's actually just 2x HX 650 that have died , the first one lasted since I got it 18.10.2010 to 26.10.2011 Aprox , then the replacement which lasted for 4 months without issues when it suddenly just overnight refused to start up again.

 

The system affected (The one in the windows is my 2nd build) has an M4A78-E Asus Motherboard, 4870 - 512Mb Gpu , 8Gb DDR2 (Kings 9CL) Phenom II x6 @ Stock Speed and 5xHd +1 optical unit. Can't say I've run the system in overclocked mode either (It was tested out in 2010 to see how far I could get, but DDR2 limited the Cpu to barely attain even the rated speed so system was not OC'ed).

 

Im currently awaiting an RMA from Dustinhome.no so I can return the current PSU to them (and then to you I guess) and perhaps get some answer to what's causing this , since my PC is working 100% I'm just guessing I have been very unlucky.

 

Thanks for your time.

Link to comment
Share on other sites

  • Corsair Employees
If you are out side the USA and if it is going through a reseller it will end up back at our factory in Taiwan, but I will do some research to see if there is anything to what you have reported. If you have the lot code off of any of the units you returned that would help immensely?
Link to comment
Share on other sites

The last unit being returned has S/N : R1109B73060127 Rev : B5W

As for the first unit I got it after all inn 2010 and can't say I can recall the S/N , If needed I can show a proof of purchase but I hope there's no doubt to me owning these units right?

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...