Jump to content
Corsair Community

[FIX] Vengeance 1500 crackling solution.


Recommended Posts

Hello. Just registered to share my solution with those experiencing annoying crackling using these (or any other USB) headsets.


All you need to do is disable Hardware Acceleration.


By doing so am I able to listen to crackle free music via both YouTube and WinAmp. Not sure how it will work in games, etc.


I'm sure it's somehow driver related as I had similar problems with Creative HS-1000 using the outdated WinXP drivers. When upgrading to W7 and newer driver versions did the crackling disappear. Hoping for driver updates to the Vengeance 1500's now.


Here's a quick guide I made for those needing help on how to turn it off in both YouTube (flash) and Winamp.



Rightclick the video window and select "Settings..."

Untick the box next to "Enable Hardware Acceleration".

Click the "Close" button.





Start by clicking the orange Main Menu icon on top left to access the menu. (or use Ctrl+P quick command)

Scroll down to Options > Preferences.




Locate "Output" under Plug-ins on the left menu.

Default output plugin should already be selected, click Configure.

Specify your Corsair Vengeance 1500 in the Device list.

Untick "Allow Hardware Acceleration" box.

Press OK.




Hope this helped, happy listening and fraggin'! ;)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...