Jump to content
Corsair Community

M90: Can't create any macros?


TankErdin

Recommended Posts

I'm trying to set up buttons on my M90, but when I try to write a macro, the first keypress I make after hitting MR immediately switches everything over to button 1/left click instead of recording anything. Sadly, I couldn't find anything in any other thread about it.
Link to comment
Share on other sites

  • 1 month later...

 

I'm not sure how this is a proposed solution for this. I have the same exact problem.

 

I know how to record a macro properly. I've read the manual. When I'm using the new beta software, I have to import my key mappings because I do not have the ability to record. Every button I press when recording gets input as "button1".

 

I have to remove the beta version, install version 1, record my macros, export them, remove version 1, re-install beta, then import my mappings. It's pretty annoying. And all this so I can use hardware mode, because I cannot seem to play SWTOR without it on.

 

But telling somebody to read the manual isn't really a justified solution is it?

Link to comment
Share on other sites

Please provide examples of specific macro's you are trying to record and for what game.

 

Mine are simply: R to button 3, E to button 6 and Q (repeat while holding) to button 7. But this happens any key I press or any function I try to assign after hitting MR.

 

I've tried them with 3 different games: The Darkness II, Syndicate (both require hardware playback) and Call of Duty MW3. Everything works fine if I import the profiles created with version 1.0

Plus, I'm able to edit already existing macros with 2.12

Link to comment
Share on other sites

Please provide examples of specific macro's you are trying to record and for what game.

 

It does not matter what game, as the issue is with the macro software.

 

When I go to record, I hit MR, then *ANY* button I hit on the keyboard, gets recorded as "Button: Left". Then, after the first button I hit, the MR button gets turned off and the final macro that is recorded is just "Button: Left"

 

I've tried EVERY button on the keyboard, ESC, all the letters, numbers, CTL, SHIFT, you name it.

 

And like I said before, If I re-install Version 1, it records fine, so the issue is with the software.

Link to comment
Share on other sites

  • Corsair Employees

First make sure you are using software 2.12 for your device. It can be found on the http://www.corsair.com website under your product.

 

Make sure you running the macro from hardware playback, and you have saved the profile/macro to the device.

 

Macros you wish to set up as a key press, please follow these steps:

http://forum.corsair.com/v3/showthread.php?t=104531

 

The R to button 3 example, what is the function of the macro?

Link to comment
Share on other sites

The R to button 3 example, what is the function of the macro?

that's for reloading, it needs just a normal press.

Q is for melee, and I need that to be repeated, not to be held, so the 3rd playback option is fine for me ;):

Link to comment
Share on other sites

First make sure you are using software 2.12 for your device. It can be found on the http://www.corsair.com website under your product.

 

Make sure you running the macro from hardware playback, and you have saved the profile/macro to the device.

 

Macros you wish to set up as a key press, please follow these steps:

http://forum.corsair.com/v3/showthread.php?t=104531

 

The R to button 3 example, what is the function of the macro?

 

I'm sorry but I don't think you are understanding.

 

I HIT MR. IT FLASHES WAITING FOR ME TO START RECORDING.

 

I HIT **ANY** BUTTON AND IT GETS RECORDED AS "BUTTON:LEFT"

 

IT DOES **NOT** DO THIS WHEN I USE VERSION 1 SOFTWARE.

 

Please read that over a few times so you can understand what I'm saying. I am doing everything correctly. I troubleshoot computers all day for a living. When something works in one software, but not in another, that means it's the software. The mouse is working fine. The software does not register the buttons properly when recording the macro.

Link to comment
Share on other sites

  • Corsair Employees

veesix:

 

For normal reloading, select hardware playback, record your macro, you can use the firmware playback option and delays should not matter. Make sure you go to the manage profile TAB and save the macro to the device.

 

fboots:

 

I see what you are saying. That is very odd. Can you confirm it does this on another machine?

Link to comment
Share on other sites

fboots:

 

I see what you are saying. That is very odd. Can you confirm it does this on another machine?

 

OK I just tried another computer and it does the same thing. I do not, however, understand what that tells us from a troubleshooting perspective.

Link to comment
Share on other sites

It sounds like the mouse may be defective. Have you tried to re flash the firmware?

 

Yes. I re-installed my entire operating system the other day and re-flashing was the first thing that I did.

 

It's obvious that it's probably something with the hardware, but it's just strange that everything works fine with Version 1 of the software. If you have any other ideas, I'm willing to try them.

Link to comment
Share on other sites

I may have found a solution for the problem fboots is having too.

let's say that I want to assign a macro to button 6. after clicking MR, as we've told, the selection goes to another random button (in my case). without clicking MR again, I can select again button 6 and than record the macro. after that, click MR to confirm the recording is finished.

works for me, although sometimes it's faulty.

Link to comment
Share on other sites

I may have found a solution for the problem fboots is having too.

let's say that I want to assign a macro to button 6. after clicking MR, as we've told, the selection goes to another random button (in my case). without clicking MR again, I can select again button 6 and than record the macro. after that, click MR to confirm the recording is finished.

works for me, although sometimes it's faulty.

 

Well, for me, it doesn't input a "random" key. It's always "Button:Left". I'm at work right now and will tinker with it when I get home in a couple hours.

Link to comment
Share on other sites

You must hit MR then select the button, not select the button, then hit MR.

 

Yes. I understand that. I was trying to do what veesix posted, which didn't work.

 

Honestly this is starting to really annoy me. I love this mouse, but it's clearly been released way too early. I paid a lot of money to be a beta tester. Sigh.

Link to comment
Share on other sites

you're welcome fboots, but let me clarify, just in case.

basically my mistake was the one described by RAM GUY: you have to hit MR then select the button, while (if I remember correctly) on version 1.0 it was the opposite way.

Trouble is, on 2.12, hitting MR causes the sw to select a random button - for me. once that happens, I can shift to the button I want to assign the macro to.

 

p.s. just to be clear, by "button" I mean the phisical buttons located on the mouse, to whom assign an action/macro.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...