Jump to content
Corsair Community

New Vengeance K90 firmware update stuck at "erasing flash memory" ???


s1rrah

Recommended Posts

Hi ...

 

Just picked up a K90 today and everything worked out of the box.

 

I did not install the driver software (K90 setup beta2.12 010612.exe) as it said a firmware update was first necessary and so I straight away began the firmware update process.

 

The update has been at the "erasing flash memory" dialogue window for about 30 minutes now.

 

Is this normal?

 

I'm really wanting to just hit "exit" as I can't believe a firmware erasure would take half an hour but thought I'd hit this forum up before officially blowing up my 45minute old, new keboard. LOL ...

 

Any tips?

 

Thanks in advance...

Joel

Link to comment
Share on other sites

After an hour I just hit "exit" and restarted my machine.

 

Now the keyboard is officially bricked.

 

I've tried it in a couple other machines (XP and Win 7) and though the keys work when pressed, I get no back lighting and the firmware update gives a "not detected, reinstall drivers message".

 

It was an awesome keyboard for about five minutes but unfortunately the update process fried it some how.

 

Back to square one.

 

I'm going to try another one cause I love the design and very bright backlighting is a must for me so hopefully the next one will work.

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...