Jump to content
Corsair Community

Force 3 120 GB not detected in BIOS


Recommended Posts

Just bought a new Force 3 120 GB drive (serial 1204) to replace my 1.5 TB seagate but couldn't get it work with my asus p5k premium Wifi MB (latest BIOS) - neither in AHCI nor IDE.


I pretty much tried everything... Switching around ports, cables (tried 3 different) and power connectors. My seagate and DVD drive are detected, but my SSD won't show up (neither alone nor with the 2 drives mentioned before).


Strange thing is that the SSD is detected on my even older nforce4 board PC (IDE only, since there was no AHCI back then).


Does anybody have an idea what could be the problem?

Link to comment
Share on other sites



This is a custom bios to make the ssd work on your board. Look for "Smushin" and the download link is there. You can also check your bios against the current on on asus's official page and try it also if you're behind on the version. Also are you using XP by chance? Thanks

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...